]> git.pld-linux.org Git - SPECS.git/blob - perl-Exception-Class.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / perl-Exception-Class.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Exception
6 %define         pnam    Class
7 Summary:        Exception::Class - declare real exception classes in Perl
8 Summary(pl.UTF-8):      Exception::Class - deklarowanie prawdziwych klas wyjątków w Perlu
9 Name:           perl-Exception-Class
10 Version:        1.44
11 Release:        1
12 License:        Artistic 2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Exception/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  6b5bb8e4ad2b1f6120fc1d33ae45e91b
16 URL:            http://search.cpan.org/dist/Exception-Class/
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Data-Inheritable >= 0.02
22 BuildRequires:  perl-Devel-StackTrace >= 2.00
23 BuildRequires:  perl-Test-Simple >= 0.96
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreq      perl($isa)
29
30 %description
31 Exception::Class allows you to declare exceptions in your modules
32 in a manner similar to how exceptions are declared in Java.
33
34 %description -l pl.UTF-8
35 Exception::Class pozwala na deklarowanie w modułach wyjątków
36 w sposób podobny do stosowanego w Javie.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes LICENSE
60 %dir %{perl_vendorlib}/Exception
61 %{perl_vendorlib}/Exception/Class.pm
62 %{perl_vendorlib}/Exception/Class
63 %{_mandir}/man3/Exception::Class*.3pm*
This page took 0.210548 seconds and 3 git commands to generate.