]> git.pld-linux.org Git - SPECS.git/blob - perl-Crypt-TEA.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / perl-Crypt-TEA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    TEA
7 Summary:        Crypt::TEA Perl module - Tiny Encryption Algorithm
8 Summary(pl.UTF-8):      Moduł Perla Crypt::TEA - Tiny Encryption Algorithm
9 Name:           perl-Crypt-TEA
10 Version:        1.25
11 Release:        16
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  6e53511e455724b40007e4f2c0050270
16 URL:            http://search.cpan.org/dist/Crypt-TEA/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module implements TEA (Tiny Encryption Algorithm) encryption. It
23 supports the Crypt::CBC interface. TEA is a 64-bit symmetric block
24 cipher with a 128-bit key and a variable number of rounds (32 is
25 recommended). It has a low setup time, and depends on a large number
26 of rounds for security, rather than a complex algorithm. It was
27 developed by David J. Wheeler and Roger M. Needham, and is described
28 at <http://www.ftp.cl.cam.ac.uk/ftp/papers/djw-rmn/djw-rmn-tea.html>.
29
30 %description -l pl.UTF-8
31 Ten moduł jest implementacją szyfrowania TEA (Tiny Encryption
32 Algorithm - niewielki algorytm szyfrowania). Obsługuje interfejs
33 Crypt::CBC. TEA jest 64-bitowym symetrycznym szyfrem blokowym ze
34 128-bitowym kluczem i zmienną liczbą kroków (zaleca się 32). Wymaga
35 mało czasu do uruchomienia i dla zapewnienia bezpieczeństwa polega na
36 dużej liczbie kroków, a nie skomplikowanym algorytmie. TEA został
37 opracowany przez Davida J. Wheelera i Rogera M. Needhama, a jego opis
38 można znaleźć pod adresem:
39 <http://www.ftp.cl.cam.ac.uk/ftp/papers/djw-rmn/djw-rmn-tea.html>.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorarch}/Crypt/TEA.pm
66 %dir %{perl_vendorarch}/auto/Crypt/TEA
67 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/TEA/*.so
68 %{_mandir}/man3/*
This page took 1.489546 seconds and 3 git commands to generate.