]> git.pld-linux.org Git - SPECS.git/blob - perl-Crypt-Eksblowfish.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / perl-Crypt-Eksblowfish.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Eksblowfish
7 Summary:        Crypt::Eksblowfish - the Eksblowfish block cipher
8 Name:           perl-Crypt-Eksblowfish
9 Version:        0.009
10 Release:        11
11 License:        Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  d2907b00cc500fc523bf86bb427d9bb8
15 URL:            http://search.cpan.org/dist/Crypt-Eksblowfish/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  perl-Class-Mix
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Crypt::Eksblowfish - An object of this type encapsulates a keyed instance of the Eksblowfish block cipher, ready to encrypt and decrypt
23
24 %prep
25 %setup -q -n %{pdir}-%{pnam}-%{version}
26
27 %build
28 %{__perl} Makefile.PL \
29         INSTALLDIRS=vendor
30
31 %{__make} \
32         CC="%{__cc}" \
33         OPTIMIZE="%{rpmcflags}"
34
35 %{?with_tests:%{__make} test}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc Changes README
49 %{perl_vendorarch}/Crypt/*.pm
50 %dir %{perl_vendorarch}/Crypt/Eksblowfish
51 %{perl_vendorarch}/Crypt/Eksblowfish/*.pm
52 %dir %{perl_vendorarch}/auto/Crypt/Eksblowfish
53 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Eksblowfish/Eksblowfish.so
54 %{_mandir}/man3/Crypt::*.3pm*
This page took 0.102761 seconds and 3 git commands to generate.