]> git.pld-linux.org Git - SPECS.git/blob - perl-CatalystX-Component-Traits.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / perl-CatalystX-Component-Traits.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    CatalystX
6 %define pnam    Component-Traits
7 Summary:        CatalystX::Component::Traits - Automatic Trait Loading and Resolution for Catalyst Components
8 Summary(pl.UTF-8):      CatalystX::Component::Traits - automatyczne ładowanie Trait oraz rozwiązywanie dla komponentów Catalyst
9 Name:           perl-CatalystX-Component-Traits
10 Version:        0.16
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CatalystX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7165156a9ebc786146c710d2939f9c06
17 URL:            http://search.cpan.org/dist/CatalystX-Component-Traits/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Moose::Autobox)
22 BuildRequires:  perl(MooseX::Traits::Pluggable) >= 0.08
23 BuildRequires:  perl-Catalyst >= 5.80005
24 BuildRequires:  perl-List-MoreUtils
25 BuildRequires:  perl-Module-Pluggable >= 3.9
26 BuildRequires:  perl-namespace-autoclean
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Adds a Catalyst::Component/COMPONENT method to your Catalyst component
33 base class that reads the optional traits parameter from app and
34 component config and instantiates the component subclass with those
35 traits using MooseX::Traits/new_with_traits from
36 MooseX::Traits::Pluggable.
37
38 # %description -l pl.UTF-8 # TODO
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %dir %{perl_vendorlib}/CatalystX
63 %dir %{perl_vendorlib}/CatalystX/Component
64 %{perl_vendorlib}/CatalystX/Component/*.pm
65 %{_mandir}/man3/*
This page took 0.96274 seconds and 3 git commands to generate.