]> git.pld-linux.org Git - SPECS.git/blob - perl-Catalyst-Plugin-ConfigLoader.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-Catalyst-Plugin-ConfigLoader.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Catalyst
6 %define pnam    Plugin-ConfigLoader
7 Summary:        Catalyst::Plugin::ConfigLoader - load config files of various types
8 Summary(pl.UTF-8):      Catalyst::Plugin::ConfigLoader - wczytywanie różnych plików konfiguracyjnych
9 Name:           perl-Catalyst-Plugin-ConfigLoader
10 Version:        0.30
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Catalyst/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d6cd604120535d5c0ab1160c3a097187
17 URL:            http://search.cpan.org/dist/Catalyst-Plugin-ConfigLoader/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Catalyst >= 5.7008
22 BuildRequires:  perl-Config-Any >= 0.08
23 BuildRequires:  perl-Data-Visitor >= 0.24
24 BuildRequires:  perl-MRO-Compat >= 0.09
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module will attempt to find and load a configuration file of
31 various types. Currently it supports YAML, JSON, XML, INI and Perl
32 formats.
33
34 To support the distinction between development and production
35 environments, this module will also attemp to load a local config
36 (e.g. myapp_local.yaml) which will override any duplicate settings.
37
38 %description -l pl.UTF-8
39 Ten moduł próbuje odnaleźć i wczytać pliki konfiguracyjne różnych
40 rodzajów. Aktualnie obsługuje formaty YAML, JSON, XML, INI i Perl.
41
42 Aby obsłużyć rozróżnienie między środowiskiem programistycznym a
43 produkcyjnym, moduł ten próbuje także wczytać lokalny plik
44 konfiguracyjny (np. myapp_local.yaml), który przykryje wszystkie
45 powtarzające się ustawienia.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} -MExtUtils::MakeMaker -we 'WriteMakefile(NAME=>"Catalyst::Plugin::ConfigLoader")' \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/Catalyst/Plugin/*.pm
70 %{_mandir}/man3/*
This page took 0.07813 seconds and 3 git commands to generate.