]> git.pld-linux.org Git - SPECS.git/blob - perl-Catalyst-Devel.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / perl-Catalyst-Devel.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Catalyst
6 %define pnam    Devel
7 Summary:        Catalyst::Devel - Catalyst Development Tools
8 #Summary(pl.UTF-8):
9 Name:           perl-Catalyst-Devel
10 Version:        1.21
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Catalyst/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  79e3ee5c14e920c04dec0259d1cfd536
17 URL:            http://search.cpan.org/dist/Catalyst-Devel/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Catalyst::Action::RenderView) >= 0.04
22 BuildRequires:  perl(Catalyst::Plugin::Static::Simple) >= 0.16
23 BuildRequires:  perl(Config::General) >= 2.42
24 BuildRequires:  perl(parent)
25 BuildRequires:  perl-Catalyst >= 5.80000
26 BuildRequires:  perl-Catalyst-Plugin-ConfigLoader
27 BuildRequires:  perl-Class-Accessor
28 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
29 BuildRequires:  perl-File-ChangeNotify >= 0.07
30 BuildRequires:  perl-File-Copy-Recursive
31 BuildRequires:  perl-Module-Install >= 0.91
32 BuildRequires:  perl-Path-Class >= 0.09
33 BuildRequires:  perl-Template-Toolkit >= 2.14
34 %endif
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The Catalyst-Devel distribution includes a variety of modules useful
40 for the development of Catalyst applications, but not required to run
41 them. This is intended to make it easier to deploy Catalyst apps. The
42 runtime parts of Catalyst are now known as Catalyst::Runtime.
43
44 Catalyst-Devel includes the Catalyst::Helper system, which
45 autogenerates scripts and tests; Module::Install::Catalyst, a
46 Module::Install extension for Catalyst; and requirements for a variety
47 of development-related modules. The documentation remains with
48 Catalyst::Runtime.
49
50 # %description -l pl.UTF-8
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} pure_install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes
74 %{perl_vendorlib}/Catalyst/*.pm
75 %dir %{perl_vendorlib}/Catalyst/Restarter
76 %{perl_vendorlib}/Catalyst/Restarter/*.pm
77 %{perl_vendorlib}/Module/Install/*.pm
78 %{_mandir}/man3/*
This page took 0.075568 seconds and 3 git commands to generate.