]> git.pld-linux.org Git - SPECS.git/blob - perl-Carp-Assert.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / perl-Carp-Assert.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Carp
6 %define         pnam    Assert
7 Summary:        Carp::Assert - executable comments
8 Summary(pl.UTF-8):      Carp::Assert - wykonywalne komentarze
9 Name:           perl-Carp-Assert
10 Version:        0.21
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Carp/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  72e75c152cc354420719fc9728deec71
17 URL:            http://search.cpan.org/dist/Carp-Assert/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Pod-Tests >= 0.18
21 BuildRequires:  perl-Test-Simple >= 0.40
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Carp::Assert is intended for a purpose like the ANSI C library
29 assert.h. An assertion is used to prevent the impossible from being
30 asked of your code, or at least tell you when it does.
31
32 %description -l pl.UTF-8
33 Moduł Carp::Assert służy do tego, co assert.h z ANSI C. Używa się
34 zapewnień (assertion), aby wykluczyć występowanie rzeczy niemożliwych,
35 albo przynajmniej wiedzieć, gdzie się zdarzają.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/Carp/Assert.pm
60 %{_mandir}/man3/Carp::Assert.3pm*
This page took 0.123529 seconds and 3 git commands to generate.