]> git.pld-linux.org Git - SPECS.git/blob - perl-Bot-Pastebot.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-Bot-Pastebot.spec
1 # TODO
2 # - make noarch
3 #
4 # Conditional build:
5 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
6 %bcond_without  tests   # do not perform "make test"
7 #
8 %define         pdir    Bot
9 %define         pnam    Pastebot
10 Summary:        The original clipboard-to-chat gateway
11 Name:           perl-Bot-Pastebot
12 Version:        0.50
13 Release:        0.1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://dl.sourceforge.net/pastebot/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  c95628bdc58bbc472728ba43e23e9792
19 URL:            http://sourceforge.net/projects/pastebot/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with autodeps} || %{with tests}
23 BuildRequires:  perl-File-ShareDir
24 BuildRequires:  perl-POE
25 BuildRequires:  perl-POE-Component-IRC
26 BuildRequires:  perl-Text-Template
27 BuildRequires:  perl-libwww
28 BuildRequires:  perltidy
29 %endif
30 # no arch files installed, but pkg installs to arch dir so therefore noarch
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Pastebot is an IRC bot that saves channels from large amounts of
36 pasted material. Text is pasted into a web form, and the bot announces
37 an URL where it can be read. Interested people can partake in the joy
38 without the whole channel scrolling to hell.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 # Don't use pipes here: they generally don't work. Apply a patch.
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README CHANGES
64
65 %attr(755,root,root) %{_bindir}/pastebot
66 %{_mandir}/man1/pastebot.1p*
67 %{perl_vendorarch}/Bot/Pastebot
68 %{perl_vendorarch}/auto/Bot/Pastebot
This page took 0.135866 seconds and 3 git commands to generate.