]> git.pld-linux.org Git - SPECS.git/blob - perl-Audio-OSS.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / perl-Audio-OSS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Audio
6 %define         pnam    OSS
7 Summary:        Audio::OSS Perl module - interface to Open Sound System
8 Summary(pl.UTF-8):      Moduł Perla Audio::OSS - interfejs do Open Sound System
9 Name:           perl-Audio-OSS
10 Version:        0.0501
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8c77167acea908501c243be198149efb
17 URL:            http://search.cpan.org/dist/Audio-OSS/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Provides:       perl(Audio::OSS::Constants)
21 # it uses C code only at build time - built package doesn't contain any binaries
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module provides a pure-Perl, no-nonsense, filehandle-based
27 interface to the Open Sound System. Audio::DSP is fine for simple,
28 blocking audio I/O, but it doesn't hold up when you want to do
29 something more complicated. That is, it doesn't expose the features of
30 the audio device interface that are required to do things like
31 non-blocking audio, real-time control of playback, querying the
32 capabilities of the audio device, finding the supported sampling
33 rates, etc. Audio::OSS provides a procedural interface based around
34 filehandles opened on the audio device (usually /dev/dsp* for PCM
35 audio). It also defines constants for various ioctl calls and other
36 things based on the OSS system header files, so you don't have to rely
37 on .ph files that may or may be correct or even present on your
38 system.
39
40 %description -l pl.UTF-8
41 Ten moduł udostępnia czysto perlowy, logiczny, oparty na uchwytach
42 plików interfejs do systemu dźwięku Open Sound. Audio::DSP jest dobry
43 do prostego, blokującego odtwarzania/nagrywania dźwięku, ale nie
44 wystarcza, jeśli trzeba zrobić coś bardziej skomplikowanego. To znaczy
45 nie udostępnia możliwości interfejsu OSS potrzebnych do rzeczy takich
46 jak nie blokujący dźwięk, kontrola odtwarzania w czasie rzeczywistym,
47 odczytywanie możliwości urządzenia dźwiękowego, sprawdzanie
48 obsługiwanych częstotliwości próbkowania itp. Moduł Audio::OSS
49 udostępnia proceduralny interfejs oparty na uchwytach plików
50 związanych z urządzeniem dźwiękowym (zazwyczaj /dev/dsp* dla dźwięku
51 PCM). Moduł także definiuje stałe dla różnych wywołań ioctl oraz
52 innych rzeczy związanych z plikami nagłówkowymi OSS, więc nie trzeba
53 polegać na plikach .ph.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README
77 %{perl_vendorlib}/Audio/OSS.pm
78 %{perl_vendorlib}/Audio/OSS
79 %{_mandir}/man3/*
This page took 0.274663 seconds and 3 git commands to generate.