]> git.pld-linux.org Git - SPECS.git/blob - perl-AnyEvent-Yubico.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / perl-AnyEvent-Yubico.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # run tests (require network)
4 #
5 %define         pdir    AnyEvent
6 %define         pnam    Yubico
7 Summary:        AnyEvent based Perl module for validating YubiKey OTPs
8 Summary(pl.UTF-8):      Oparty na AnyEvent moduł Perla do sprawdzania poprawności OTP YubiKey
9 Name:           perl-AnyEvent-Yubico
10 Version:        0.9.3
11 Release:        1
12 License:        BSD
13 Group:          Development/Languages/Perl
14 #Source0Download: https://github.com/Yubico/yubico-perl-client/releases
15 Source0:        https://github.com/Yubico/yubico-perl-client/archive/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  28cc626e6531e85767399c7d6164c1f6
17 URL:            https://developers.yubico.com/yubico-perl-client/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-AnyEvent-HTTP >= 2.13
22 BuildRequires:  perl-Digest-HMAC >= 1.02
23 BuildRequires:  perl-MIME-Base64 >= 3.13
24 BuildRequires:  perl-Net-SSLeay >= 1.36
25 BuildRequires:  perl-Test-Exception >= 0.29
26 BuildRequires:  perl-Test-Simple >= 0.98
27 BuildRequires:  perl-URI >= 1.54
28 BuildRequires:  perl-UUID-Tiny >= 1.0
29 %endif
30 Requires:       perl-AnyEvent-HTTP >= 2.13
31 Requires:       perl-Digest-HMAC >= 1.02
32 Requires:       perl-MIME-Base64 >= 3.13
33 Requires:       perl-URI >= 1.54
34 Requires:       perl-UUID-Tiny >= 1.0
35 Conflicts:      perl-Net-SSLeay < 1.36
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 AnyEvent based Perl module for validating YubiKey OTPs.
41
42 %description -l pl.UTF-8
43 Oparty na AnyEvent moduł Perla do sprawdzania poprawności OTP YubiKey.
44
45 %prep
46 %setup -q -n yubico-perl-client-%{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc COPYING Changes README
68 %{perl_vendorlib}/AnyEvent/Yubico.pm
69 %{_mandir}/man3/AnyEvent::Yubico.3pm*
This page took 0.185754 seconds and 3 git commands to generate.