]> git.pld-linux.org Git - SPECS.git/blob - perl-Algorithm-C3.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-Algorithm-C3.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Algorithm
6 %define pnam    C3
7 Summary:        Algorithm::C3 - A module for merging hierarchies using the C3 algorithm
8 Summary(pl.UTF-8):      Algorithm::C3 - moduł do łączenia hierarchii przy użyciu algorytmu C3
9 Name:           perl-Algorithm-C3
10 Version:        0.10
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Algorithm/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  48162c8974b3056c1315203efc7d8748
17 URL:            http://search.cpan.org/dist/Algorithm-C3/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 C3 is the name of an algorithm which aims to provide a sane method
25 resolution order under multiple inheritance. It was first introduced
26 in the Dylan language (see links in the manual SEE ALSO section), and
27 then later adopted as the preferred MRO (Method Resolution Order) for
28 the new-style classes in Python 2.3. Most recently it has been adopted
29 as the 'canonical' MRO for Perl 6 classes, and the default MRO for
30 Parrot objects as well.
31
32 %description -l pl.UTF-8
33 C3 to nazwa algorytmu, którego celem jest dostarczenie rozsądnej
34 kolejności rozwiązywania metod przy wielokrotnym dziedziczeniu. Po raz
35 pierwszy został wprowadzony w języku Dylan (odnośniki w sekcji SEE
36 ALSO manuala), a następnie zaadoptowany jako preferowana MRO (Method
37 Resolution Order - kolejność rozwiązywania metod) dla nowego stylu
38 klas w Pythonie 2.3. Ostatnio został zaadoptowany jako "kanoniczna"
39 MRO dla klas Perla 6 i domyślna MRO dla obiektów Parrota.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         destdir=$RPM_BUILD_ROOT \
47         installdirs=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/Algorithm/*.pm
64 %{_mandir}/man3/*
This page took 0.032686 seconds and 3 git commands to generate.