]> git.pld-linux.org Git - SPECS.git/blob - pcre++.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / pcre++.spec
1 Summary:        C++ wrapper around the PCRE library
2 Summary(pl.UTF-8):      Nakładka na bibliotekę PCRE dla C++
3 Name:           pcre++
4 Version:        0.9.5
5 Release:        6
6 License:        LGPL
7 Group:          Libraries
8 Source0:        ftp://ftp.daemon.de/scip/Apps/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  1fe6ea8e23ece01fde2ce5fb4746acc2
10 Patch0:         %{name}-DESTDIR.patch
11 URL:            http://www.daemon.de/PCRE
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRequires:  pcre-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 PCRE++ is a C++ wrapper-class for PCRE library (Perl Compatible
21 Regular Expressions). It allows you to use Perl-alike regular
22 expressions in your C++ applications. You can use it to search in
23 strings, to split strings into parts using expressions, or to search
24 and replace a part of a string with another part.
25
26 %description -l pl.UTF-8
27 PCRE++ jest klasą-nakładką dla C++ na bibliotekę PCRE (Perl Compatible
28 Regular Expressions - perlowych wyrażeń regularnych). Pozwala na
29 korzystanie ze składni perlowych wyrażeń regularnych w aplikacjach
30 C++. Można przeszukiwać w tekstach, dzielić tekst korzystając z
31 różnych wyrażeń lub wyszukiwać i zamieniać fragmenty tekstu innymi
32 częściami.
33
34 %package devel
35 Summary:        Header files for pcre++ library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki pcre++
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       libstdc++-devel
40 Requires:       pcre-devel
41
42 %description devel
43 Header files for pcre++ library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki pcre++.
47
48 %package static
49 Summary:        Static pcre++ library
50 Summary(pl.UTF-8):      Statyczna biblioteka pcre++
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static pcre++ library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka pcre++.
59
60 %prep
61 %setup -q
62 %patch0
63
64 %build
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 %configure
71 %{__make} \
72         CXXFLAGS="%{rpmcflags} -Wall"
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 rm -rf lib%{name}-%{version}
81 mv $RPM_BUILD_ROOT%{_prefix}/doc/lib%{name}-%{version} .
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog NEWS README TODO
92 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
93
94 %files devel
95 %defattr(644,root,root,755)
96 %doc lib%{name}-%{version}/*
97 %attr(755,root,root) %{_bindir}/*
98 %attr(755,root,root) %{_libdir}/lib*.so
99 %{_libdir}/lib*.la
100 %{_includedir}/%{name}.h
101 %{_mandir}/man3/*
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/lib*.a
This page took 0.524422 seconds and 3 git commands to generate.