]> git.pld-linux.org Git - SPECS.git/blob - ossp-str.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / ossp-str.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 %define tarballname str
6 #
7 Summary:        OSSP str - string handling library
8 Summary(pl.UTF-8):      OSSP str - biblioteka do obsługi łańcuchów znaków
9 Name:           ossp-str
10 Version:        0.9.12
11 Release:        0.1
12 License:        distributable (see README)
13 Group:          Libraries
14 Source0:        ftp://ftp.ossp.org/pkg/lib/str/%{tarballname}-%{version}.tar.gz
15 # Source0-md5:  3f6da8a6ae6662eedf481f11a65592b2
16 Patch0:         %{name}-DESTDIR.patch
17 URL:            http://www.ossp.org/pkg/lib/str/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 OSSP str is a generic string library written in ISO-C which provides
25 functions for handling, matching, parsing, searching and formatting of
26 ISO-C strings. So it can be considered as a superset of POSIX
27 string(3), but its main intention is to provide a more convenient and
28 compact API plus a more generalized functionality.
29
30 %description -l pl.UTF-8
31 OSSP str to ogólna biblioteka do łańcuchów znaków napisana w ISO-C,
32 dostarczająca funkcje do obsługi, przetwarzania, przeszukiwania i
33 formatowania łańcuchów znaków ISO-C. Może być uznawana za nadzbiór
34 string(3) wg POSIX, ale głównym zamiarem jest dostarczenie bardziej
35 wygodnego i zwartego API oraz ogólniejszej funkcjonalności.
36
37 %package devel
38 Summary:        OSSP str - header files and development libraries
39 Summary(pl.UTF-8):      OSSP str - pliki nagłówkowe i biblioteki programistyczne
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 OSSP str - header files and development libraries.
45
46 %description devel -l pl.UTF-8
47 OSSP str - pliki nagłówkowe i biblioteki programistyczne.
48
49 %package static
50 Summary:        OSSP str - string handling library - static libraries
51 Summary(pl.UTF-8):      OSSP str - biblioteka do obsługi łańcuchów znaków - biblioteki statyczne
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 OSSP str - string handling library - static libraries.
57
58 %description static -l pl.UTF-8
59 OSSP str - biblioteka do obsługi łańcuchów znaków - biblioteki
60 statyczne.
61
62 %prep
63 %setup -q -n %{tarballname}-%{version}
64 %patch0 -p1
65
66 %build
67 mv -f aclocal.m4 acinclude.m4
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %configure \
72         %{!?with_static_libs:--enable-static=no}
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS ChangeLog LICENSE README THANKS TODO
90 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
91
92 %files devel
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_bindir}/*
95 %attr(755,root,root) %{_libdir}/lib*.so
96 %{_libdir}/lib*.la
97 %{_includedir}/*
98 %{_mandir}/man[13]/*
99
100 %if %{with static}
101 %files static
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/lib*.a
104 %endif
This page took 0.333737 seconds and 3 git commands to generate.