]> git.pld-linux.org Git - SPECS.git/blob - opentsdb.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / opentsdb.spec
1 Summary:        A scalable, distributed Time Series Database
2 Name:           opentsdb
3 Version:        2.1.0
4 Release:        0.1
5 License:        LGPL v2.1+
6 Group:          Applications/Databases
7 Source0:        https://github.com/OpenTSDB/opentsdb/releases/download/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  8438173a0b0ddfcbd49b731870ca9f4c
9 URL:            http://opentsdb.net/
10 Requires:       gnuplot
11 Requires:       jre
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 OpenTSDB is a distributed, scalable Time Series Database (TSDB)
17 written on top of HBase. OpenTSDB was written to address a common
18 need: store, index and serve metrics collected from computer systems
19 (network gear, operating systems, applications) at a large scale, and
20 make this data easily accessible and graphable.
21
22 Thanks to HBase's scalability, OpenTSDB allows you to collect many
23 thousands of metrics from thousands of hosts and applications, at a
24 high rate (every few seconds). OpenTSDB will never delete or
25 downsample data and can easily store billions of data points.
26
27 %prep
28 %setup -q
29
30 %build
31 %configure
32 %{__make} -j1
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT/var/cache/%{name}
37 %{__make} install -j1 \
38         DESTDIR=$RPM_BUILD_ROOT
39
40 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/bin/mygnuplot.bat
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc README THANKS NEWS AUTHORS
48 %attr(755,root,root) %{_bindir}/tsdb
49 %dir %{_datadir}/%{name}
50 %dir %{_datadir}/%{name}/bin
51 %attr(755,root,root) %{_datadir}/%{name}/bin/*.sh
52 %attr(755,root,root) %{_datadir}/%{name}/bin/tsdb
53 %{_datadir}/%{name}/tools
54 %{_datadir}/%{name}/static
55
56 # third_party
57 %dir %{_datadir}/%{name}/lib
58 %{_datadir}/%{name}/lib/async-1.4.0.jar
59 %{_datadir}/%{name}/lib/asynchbase-1.6.0.jar
60 %{_datadir}/%{name}/lib/guava-18.0.jar
61 %{_datadir}/%{name}/lib/jackson-annotations-2.4.3.jar
62 %{_datadir}/%{name}/lib/jackson-core-2.4.3.jar
63 %{_datadir}/%{name}/lib/jackson-databind-2.4.3.jar
64 %{_datadir}/%{name}/lib/log4j-over-slf4j-1.7.7.jar
65 %{_datadir}/%{name}/lib/logback-classic-1.0.13.jar
66 %{_datadir}/%{name}/lib/logback-core-1.0.13.jar
67 %{_datadir}/%{name}/lib/netty-3.9.4.Final.jar
68 %{_datadir}/%{name}/lib/protobuf-java-2.5.0.jar
69 %{_datadir}/%{name}/lib/slf4j-api-1.7.7.jar
70 %{_datadir}/%{name}/lib/tsdb-2.1.0.jar
71 %{_datadir}/%{name}/lib/zookeeper-3.3.6.jar
72
73 %dir %{_localstatedir}/cache/%{name}
74
75 # this looks like install error
76 %dir %{_datadir}/%{name}/etc
77 %dir %{_datadir}/%{name}/etc/opentsdb
78 %dir %{_datadir}/%{name}/etc/init.d
79 %{_datadir}/%{name}/etc/opentsdb/logback.xml
80 %{_datadir}/%{name}/etc/opentsdb/opentsdb.conf
81 %attr(754,root,root) %{_datadir}/%{name}/etc/init.d/opentsdb
This page took 0.311599 seconds and 3 git commands to generate.