]> git.pld-linux.org Git - SPECS.git/blob - open-cobol.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / open-cobol.spec
1 Summary:        COBOL compiler
2 Summary(pl.UTF-8):      Kompilator języka COBOL
3 Name:           open-cobol
4 Version:        1.0
5 Release:        1
6 License:        GPL/LGPL
7 Group:          Development/Languages
8 Source0:        http://dl.sourceforge.net/open-cobol/%{name}-%{version}.tar.gz
9 # Source0-md5:  947e0d9c4ee7fa8f077ea4bca2f894e5
10 URL:            http://www.opencobol.org/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  gcc-g77
14 BuildRequires:  gettext-tools
15 BuildRequires:  gmp-devel
16 BuildRequires:  libltdl-devel
17 BuildRequires:  libtool
18 BuildRequires:  ncurses-devel
19 Requires:       %{name}-libs = %{version}-%{release}
20 Requires:       gmp-devel
21 Requires:       libltdl-devel
22 Requires:       ncurses-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 OpenCOBOL is an open-source COBOL compiler. OpenCOBOL implements
27 substantial part of the COBOL 85 and COBOL 2002 standards, as well as
28 many extensions of the existent COBOL compilers. OpenCOBOL translates
29 COBOL into C and compiles the translated code using GCC. You can build
30 your COBOL programs on various platforms, including GNU/Linux, Mac OS
31 X, and Microsoft Windows. The compiler is licensed under GNU General
32 Public License. The run-time library is licensed under GNU Lesser
33 General Public License.
34
35 %description -l pl.UTF-8
36 OpenCOBOL jest kompilerem COBOLa o otwartych źródłach. OpenCOBOL
37 implementuje znaczną część standardów COBOL 85 i COBOL 2002, jak i
38 wiele z rozszerzeń z istniejących kompilatorów COBOLa. OpenCOBOL
39 tłumaczy źródła COBOLa do języka C i następnie kompiluje
40 przetłumaczony kod używając GCC. Pozwala budować programy COBOLowe na
41 wielu platformach, w tym takich jak GNU/Linux, Mac OS X i Microsoft
42 Windows. Kompilator jest objęty licencją GNU General Public License.
43 Biblioteka uruchomieniowa jest objęta licencją GNU Lesser General
44 Public License.
45
46 %package libs
47 Summary:        OpenCOBOL runtime library
48 Summary(pl.UTF-8):      Biblioteka uruchomieniowa OpenCOBOLa
49 License:        LGPL
50 Group:          Libraries
51
52 %description libs
53 OpenCOBOL runtime library.
54
55 %description libs -l pl.UTF-8
56 Biblioteka uruchomieniowa OpenCOBOLa.
57
58 %package static
59 Summary:        Static OpenCOBOL runtime library
60 Summary(pl.UTF-8):      Statyczna biblioteka uruchomieniowa OpenCOBOLa
61 License:        LGPL
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description static
66 Static OpenCOBOL runtime library, needed to build statically
67 linked COBOL programs.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka uruchomieniowa OpenCOBOLa, potrzebna do tworzenia
71 statycznie linkowanych programów w COBOLu.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__libtoolize}
78 %{__aclocal} -I m4
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   libs -p /sbin/ldconfig
98 %postun libs -p /sbin/ldconfig
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog NEWS README THANKS TODO
103 %attr(755,root,root) %{_bindir}/*
104 %{_datadir}/%{name}
105 %{_includedir}/libcob.h
106 %{_includedir}/libcob
107 %attr(755,root,root) %{_libdir}/libcob.so
108 %{_libdir}/libcob.la
109 %{_infodir}/*.info*
110
111 %files libs
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libcob.so.*.*.*
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libcob.a
This page took 0.835823 seconds and 3 git commands to generate.