]> git.pld-linux.org Git - SPECS.git/blob - ois.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / ois.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         file_version    %(echo %{version} | tr . -)
6 Summary:        Object Oriented Input System
7 Summary(pl.UTF-8):      Zorientowany obiektowo system wejścia
8 Name:           ois
9 Version:        1.3
10 Release:        2
11 License:        zlib/libpng
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/wgois/%{name}_v%{file_version}.tar.gz
14 # Source0-md5:  9697fead17eac6025151cd2e1fca1518
15 Patch0:         gcc.patch
16 URL:            http://ostatic.com/wgois/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:1.4
21 BuildRequires:  xorg-lib-libXaw-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The goal of OIS is shield the application programmer from having to
26 rewrite input systems from scratch for each project.
27
28 %description -l pl.UTF-8
29 Celem projektu OIS jest ochrona twórcy aplikacji przed przepisywaniem
30 na nowo systemów wejścia w każdym projekcie.
31
32 %package devel
33 Summary:        Header files for OIS library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OIS
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel
38 Requires:       xorg-lib-libXaw-devel
39
40 %description devel
41 Header files for OIS library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki OIS.
45
46 %package static
47 Summary:        Static OIS library
48 Summary(pl.UTF-8):      Statyczna biblioteka OIS
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static OIS library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka OIS.
57
58 %prep
59 %setup -q -n %{name}-v%{file_version}
60 %patch0 -p1
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoheader}
66 %{__automake}
67 %{__autoconf}
68 %configure \
69         %{!?with_static_libs:--disable-static}
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/libOIS-*.*.*.so
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libOIS.so
91 %{_libdir}/libOIS.la
92 %{_includedir}/OIS
93 %{_pkgconfigdir}/OIS.pc
94
95 %if %{with static_libs}
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/libOIS.a
99 %endif
This page took 0.413372 seconds and 3 git commands to generate.