]> git.pld-linux.org Git - SPECS.git/blob - ode.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / ode.spec
1 # TODO:
2 # - system libccd
3 # - assertion "bNormalizationResult" failed in _dNormalize3()
4 #   [what conditions? assert fails when passed 0-length vector, which cannot be normalized]
5 #
6 Summary:        ODE - library for simulating articulated rigid body dynamics
7 Summary(pl.UTF-8):      ODE - biblioteka służąca do symulacji dynamiki bryły sztywnej
8 Name:           ode
9 Version:        0.12
10 Release:        4
11 Epoch:          1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://downloads.sourceforge.net/opende/%{name}-%{version}.tar.bz2
15 # Source0-md5:  48fdd41fae1a7e7831feeded09826599
16 URL:            http://ode.org/
17 BuildRequires:  OpenGL-GLU-devel
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake >= 1:1.10
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  pkgconfig
24 BuildRequires:  python-Cython >= 0.14.1
25 BuildRequires:  python-devel >= 1:2.4
26 BuildRequires:  xorg-lib-libX11-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Open Dynamics Engine (ODE) is a free software library for the
31 simulation of Rigid Body Dynamics. ODE is useful for simulating things
32 like vehicles, objects in virtual reality environments, and virtual
33 creatures.
34
35 %description -l pl.UTF-8
36 Open Dynamics Engine (ODE) jest wolną biblioteką służącą do
37 symulacji dynamiki bryły sztywnej. ODE jest użyteczne przy symulacji
38 pojazdów, obiektów w przestrzeni wirtualnej i wirtualnych stworzeń.
39
40 %package devel
41 Summary:        Header files for ODE library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ODE
43 Group:          Development/Libraries
44 Requires:       %{name} = %{epoch}:%{version}-%{release}
45 Requires:       libstdc++-devel
46
47 %description devel
48 Header files for ODE library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki ODE.
52
53 %package static
54 Summary:        Static ODE library
55 Summary(pl.UTF-8):      Statyczna biblioteka ODE
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
58
59 %description static
60 Static ODE library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka ODE.
64
65 %package -n python-ode
66 Summary:        Python binding for ODE library
67 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki ODE
68 Group:          Libraries/Python
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70
71 %description -n python-ode
72 Python binding for ODE library.
73
74 %description -n python-ode -l pl.UTF-8
75 Wiązanie Pythona do biblioteki ODE.
76
77 %prep
78 %setup -q
79
80 %build
81 %configure \
82         --enable-libccd \
83         --enable-shared
84 %{__make}
85
86 srcdir="$(pwd)"
87 cd bindings/python
88 CFLAGS="%{rpmcppflags} -I$srcdir/include -DdSINGLE"
89 %py_build
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 cd bindings/python
98 %py_install
99
100 # obsoleted by pkg-config
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libode.la
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc CHANGELOG.txt README.txt
112 %attr(755,root,root) %{_libdir}/libode.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libode.so.3
114
115 %files devel
116 %defattr(644,root,root,755)
117 %doc ode/{README,TODO} ode/doc/{main.dox,pix}
118 %attr(755,root,root) %{_bindir}/ode-config
119 %attr(755,root,root) %{_libdir}/libode.so
120 %{_includedir}/ode
121 %{_pkgconfigdir}/ode.pc
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libode.a
126
127 %files -n python-ode
128 %defattr(644,root,root,755)
129 %doc bindings/python/TODO.txt
130 %attr(755,root,root) %{py_sitedir}/ode.so
131 %{py_sitedir}/Open_Dynamics_Engine-0.1-py*.egg-info
This page took 0.931834 seconds and 3 git commands to generate.