]> git.pld-linux.org Git - SPECS.git/blob - nuget.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / nuget.spec
1 Summary:        Package manager for .NET/Mono development platform
2 Summary(pl.UTF-8):      Zarządca pakietów dla platformy programistycznej .NET/Mono
3 Name:           nuget
4 Version:        2.8.7
5 Release:        1
6 License:        Apache v2.0
7 Group:          Development/Tools
8 %define veradd  md510+dhx1
9 #Source0:       http://download.mono-project.com/sources/nuget/%{name}_%{version}+%{veradd}.orig.tar.bz2
10 Source0:        https://launchpad.net/ubuntu/+archive/primary/+files/%{name}_%{version}+%{veradd}.orig.tar.bz2
11 # Source0-md5:  0fe8090470bf35f44f705c94d7150037
12 Source1:        %{name}-core.pc
13 Source2:        %{name}.sh
14 Patch0:         %{name}-fix_xdt_hintpath
15 URL:            http://nuget.org/
16 BuildRequires:  mono-devel >= 4.0
17 BuildRequires:  rpmbuild(monoautodeps)
18 BuildRequires:  sed >= 4.0
19 Requires:       dotnet-nuget = %{version}-%{release}
20 ExclusiveArch:  %{ix86} %{x8664} arm aarch64 ia64 mips ppc ppc64 s390x sparc sparcv9 sparc64
21 ExcludeArch:    i386
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 NuGet is the package manager for the Microsoft development platform
26 including .NET. The NuGet client tools provide the ability to produce
27 and consume packages. The NuGet Gallery is the central package
28 repository used by all package authors and consumers.
29
30 %description -l pl.UTF-8
31 NuGet to zarządca pakietów dla platformy programistycznej platformy
32 Microsoft, w tym .NET. Narzędzia klienckie NuGet pozwalają produkować
33 i konsumować pakiety. NuGet Gallery to centralne repozytorium pakietów
34 używane przez wszystkich autorów i konsumentów pakietów.
35
36 %package -n dotnet-nuget
37 Summary:        NuGet package manager library for .NET
38 Summary(pl.UTF-8):      Biblioteka zarządców pakietów NuGet dla .NET
39 Group:          Libraries
40 Requires:       mono >= 4.0
41
42 %description -n dotnet-nuget
43 NuGet package manager library for .NET.
44
45 %description -n dotnet-nuget -l pl.UTF-8
46 Biblioteka zarządców pakietów NuGet dla .NET.
47
48 %package -n dotnet-nuget-devel
49 Summary:        Development files for NuGet .NET library
50 Summary(pl.UTF-8):      Pliki programistyczne biblioteki .NET NuGet
51 Group:          Development/Libraries
52 Requires:       dotnet-nuget = %{version}-%{release}
53 Obsoletes:      nuget-devel
54
55 %description -n dotnet-nuget-devel
56 Development files for NuGet .NET library.
57
58 %description -n dotnet-nuget-devel -l pl.UTF-8
59 Pliki programistyczne biblioteki .NET NuGet.
60
61 %prep
62 %setup -qn %{name}-git
63 %{__sed} -i "s/\r//g" src/Core/Core.csproj
64 %patch0 -p1
65
66 # fix compile with Mono4
67 find . -name "*.csproj" -print -exec sed -i 's#ToolsVersion="3.5"#ToolsVersion="4.0"#g; s#<TargetFrameworkVersion>.*</TargetFrameworkVersion>##g; s#<PropertyGroup>#<PropertyGroup><TargetFrameworkVersion>v4.5</TargetFrameworkVersion>#g' {} \;
68
69 %build
70 xbuild xdt/XmlTransform/Microsoft.Web.XmlTransform.csproj
71 xbuild src/Core/Core.csproj /p:Configuration="Mono Release"
72 xbuild src/CommandLine/CommandLine.csproj /p:Configuration="Mono Release"
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pkgconfigdir},%{_prefix}/lib/mono/nuget}
77
78 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pkgconfigdir}/nuget-core.pc
79 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/nuget
80
81 cp -p src/CommandLine/bin/Release/NuGet.Core.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
82 cp -p xdt/XmlTransform/bin/Debug/Microsoft.Web.XmlTransform.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
83 cp -p src/CommandLine/bin/Release/NuGet.exe $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc COPYRIGHT.txt CREDITS.txt acknowledgements.md changelog.md
91 %attr(755,root,root) %{_bindir}/nuget
92 %{_prefix}/lib/mono/nuget/NuGet.exe
93
94 %files -n dotnet-nuget
95 %defattr(644,root,root,755)
96 %dir %{_prefix}/lib/mono/nuget
97 %{_prefix}/lib/mono/nuget/Microsoft.Web.XmlTransform.dll
98 %{_prefix}/lib/mono/nuget/NuGet.Core.dll
99
100 %files -n dotnet-nuget-devel
101 %defattr(644,root,root,755)
102 %{_pkgconfigdir}/nuget-core.pc
This page took 0.376466 seconds and 3 git commands to generate.