]> git.pld-linux.org Git - SPECS.git/blob - netcdf-cxx.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / netcdf-cxx.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform "make check"
4                                 # (note: tests need endoder-enabled szip)
5 #
6 Summary:        NetCDF C++ library (old API)
7 Summary(pl.UTF-8):      Biblioteka NetCDF dla języka C++ (stare API)
8 Name:           netcdf-cxx
9 Version:        4.2
10 Release:        7
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
14 # Source0-md5:  d32b20c00f144ae6565d9e98d9f6204c
15 Patch0:         %{name}-info.patch
16 URL:            https://www.unidata.ucar.edu/software/netcdf/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:2.2
21 BuildRequires:  netcdf-devel >= 4.2
22 BuildRequires:  texinfo
23 Requires:       netcdf >= 4.2
24 Obsoletes:      netcdf-c++
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 NetCDF (network Common Data Form) is an interface for array-oriented
29 data access and a library that provides an implementation of the
30 interface. The netCDF library also defines a machine-independent
31 format for representing scientific data. Together, the interface,
32 library, and format support the creation, access, and sharing of
33 scientific data. The netCDF software was developed at the Unidata
34 Program Center in Boulder, Colorado.
35
36 This package contains C++ library with old API.
37
38 %description -l pl.UTF-8
39 NetCDF (Network Common Data Form) jest interfejsem dostępu do danych
40 zorganizowanych w tablice. Biblioteka netCDF definiuje niezależny od
41 maszyny format reprezentowania danych naukowych. Interfejs oraz
42 biblioteka pozwalają na tworzenie, dostęp i współdzielenie danych.
43 NetCDF powstał w Unidata Program Center w Boulder, Colorado.
44
45 Ten pakiet zawiera bibliotekę dla języka C++ ze starym API.
46
47 %package devel
48 Summary:        Header files for netCDF C++ old interface
49 Summary(pl.UTF-8):      Pliki nagłówkowe starego interfejsu netCDF dla języka C++
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libstdc++-devel
53 Requires:       netcdf-devel >= 4.2
54 Obsoletes:      netcdf-c++-devel
55
56 %description devel
57 Header files for netCDF - old C++ interface.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki netCDF - stary interfejs dla języka C++.
61
62 %package static
63 Summary:        NetCDF C++ static library (old API)
64 Summary(pl.UTF-8):      Biblioteka statyczna netCDF dla języka C++ (stare API)
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67 Obsoletes:      netcdf-c++-static
68
69 %description static
70 Static version of netCDF C++ library with old API.
71
72 %description static -l pl.UTF-8
73 Statyczna wersja biblioteki netCDF dla języka C++ ze starym API.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure
86
87 %{__make}
88
89 %if %{with tests}
90 %{__make} -j1 check
91 %endif
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %post   devel -p /sbin/postshell
106 -/usr/sbin/fix-info-dir -c %{_infodir}
107
108 %postun devel -p /sbin/postshell
109 -/usr/sbin/fix-info-dir -c %{_infodir}
110
111 %files
112 %defattr(644,root,root,755)
113 %doc COPYRIGHT
114 %attr(755,root,root) %{_libdir}/libnetcdf_c++.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libnetcdf_c++.so.4
116
117 %files devel
118 %defattr(644,root,root,755)
119 %doc man4/netcdf-cxx.html
120 %attr(755,root,root) %{_libdir}/libnetcdf_c++.so
121 %{_libdir}/libnetcdf_c++.la
122 %{_includedir}/ncvalues.h
123 %{_includedir}/netcdf.hh
124 %{_includedir}/netcdfcpp.h
125 %{_infodir}/netcdf-cxx.info*
126
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libnetcdf_c++.a
This page took 0.051283 seconds and 3 git commands to generate.