]> git.pld-linux.org Git - SPECS.git/blob - nanomsg.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / nanomsg.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        High-performance implementation of several "scalability protocols"
6 Summary(pl.UTF-8):      Wydajna implementacja kilku "protokołów skalowalności"
7 Name:           nanomsg
8 Version:        1.1.5
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://github.com/nanomsg/nanomsg/releases
13 Source0:        https://github.com/nanomsg/nanomsg/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  272db464bac1339b6cea060dd63b22d4
15 Patch0:         %{name}-nolibs.patch
16 URL:            https://nanomsg.org/
17 BuildRequires:  cmake >= 2.8.12
18 BuildRequires:  ruby-asciidoctor
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 nanomsg library is a simple high-performance implementation of several
23 "scalability protocols". Scalability protocol's job is to define how
24 multiple applications communicate to form a single distributed
25 application.
26
27 %description -l pl.UTF-8
28 Biblioteka nanomsg to prosta, wydajna implementacja kilku "protokołów
29 skalowalności". Zadaniem takiego protokołu jest określenie, jak wiele
30 aplikacji powinno się komunikować w celu stworzenia pojedynczej
31 aplikacji rozproszonej.
32
33 %package devel
34 Summary:        Header files for nanomsg library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki nanomsg
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for nanomsg library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki nanomsg.
44
45 %package static
46 Summary:        Static nanomsg library
47 Summary(pl.UTF-8):      Statyczna biblioteka nanomsg
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static nanomsg library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka nanomsg.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 %if %{with static_libs}
63 install -d build-static
64 cd build-static
65 %cmake .. \
66         -DNN_STATIC_LIB=ON \
67         -DCMAKE_INSTALL_LIDBIR=%{_lib}
68
69 %{__make}
70 cd ..
71 %endif
72
73 install -d build
74 cd build
75 %cmake .. \
76         -DCMAKE_INSTALL_LIDBIR=%{_lib}
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %if %{with static_libs}
84 %{__make} -C build-static install \
85         DESTDIR=$RPM_BUILD_ROOT
86 %endif
87
88 %{__make} -C build install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # HTML version of man pages (generated from the same asciidoc sources)
92 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/*.html
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS COPYING README.md SUPPORT
103 %attr(755,root,root) %{_bindir}/nanocat
104 %attr(755,root,root) %{_libdir}/libnanomsg.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libnanomsg.so.5
106 %{_mandir}/man1/nanocat.1*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libnanomsg.so
111 %{_includedir}/nanomsg
112 %{_pkgconfigdir}/nanomsg.pc
113 %{_libdir}/cmake/nanomsg-%{version}
114 %{_mandir}/man3/nn_*.3*
115 %{_mandir}/man7/nanomsg.7*
116 %{_mandir}/man7/nn_*.7*
117
118 %if %{with static_libs}
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libnanomsg.a
122 %endif
This page took 0.609439 seconds and 3 git commands to generate.