]> git.pld-linux.org Git - SPECS.git/blob - lzfse.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / lzfse.spec
1 Summary:        LZFSE - Lempel-Ziv style data compression using Finite State Entropy coding
2 Summary(pl.UTF-8):      LZFSE - kompresja danych z stylu Lempel-Ziv przy użyciu kodowania entropijnego
3 Name:           lzfse
4 Version:        1.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/lzfse/lzfse/releases
9 Source0:        https://github.com/lzfse/lzfse/archive/%{name}-%{version}.tar.gz
10 # Source0-md5:  53e89f88d9cb0f4cb9c3f366dfb239a9
11 URL:            https://github.com/lzfse/lzfse
12 BuildRequires:  cmake >= 2.8.6
13 BuildRequires:  gcc >= 5:3.2
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This is a reference C implementation of the LZFSE compressor
18 introduced in the Apple Compression library with OS X 10.11 and iOS 9.
19
20 %description -l pl.UTF-8
21 Ten pakiet zawiera wzorcową implementację w C kompresora LZFSE,
22 wprowadzonego w bibliotece Compression Apple'a wraz z OS X 10.11 oraz
23 iOS 9.
24
25 %package devel
26 Summary:        Header files for LZFSE library
27 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LZFSE
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for LZFSE library.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe biblioteki LZFSE.
36
37 %prep
38 %setup -q -n %{name}-%{name}-%{version}
39
40 %build
41 install -d build
42 cd build
43 %cmake ..
44
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} -C build install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post   -p /sbin/ldconfig
57 %postun -p /sbin/ldconfig
58
59 %files
60 %defattr(644,root,root,755)
61 %doc LICENSE README.md
62 %attr(755,root,root) %{_bindir}/lzfse
63 %attr(755,root,root) %{_libdir}/liblzfse.so
64
65 %files devel
66 %defattr(644,root,root,755)
67 %{_includedir}/lzfse.h
This page took 0.517346 seconds and 3 git commands to generate.