]> git.pld-linux.org Git - SPECS.git/blob - luakit.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / luakit.spec
1
2 %bcond_with     git             # fetch the newest version from git
3
4 %if %{with git}
5 %define git_url         %{?luakit_git_url}%{!?luakit_git_url:git://github.com/mason-larobina/luakit}
6 %define git_branch      %{?luakit_git_branch}%{!?luakit_git_branch:develop}
7 %endif
8
9 %define         rel     1
10 Summary:        WebKitGTK+ based browser
11 Summary(hu.UTF-8):      WebKitGTK+ alapú böngésző
12 Summary(pl.UTF-8):      Przeglądarka oparta na WebKitGTK+
13 Name:           luakit
14 Version:        2012.03.25
15 Release:        %{rel}%{?with_git:.git.%(date +%s)}
16 License:        GPL v3
17 Group:          Applications
18 Source0:        http://github.com/mason-larobina/luakit/tarball/%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  e25aaeacfa5758127b3f677eafba9aa2
20 Patch0:         %{name}-shebang.patch
21 URL:            http://luakit.org/
22 %{?with_git:BuildRequires:      git-core}
23 BuildRequires:  glib-devel
24 BuildRequires:  gtk+2-devel
25 BuildRequires:  gtk-webkit-devel
26 BuildRequires:  help2man
27 BuildRequires:  libsoup-devel
28 BuildRequires:  libunique-devel
29 BuildRequires:  lua51
30 BuildRequires:  lua51-devel
31 BuildRequires:  pkgconfig
32 Requires:       dmenu
33 Requires:       wget
34 Suggests:       ca-certificates
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 luakit is a highly configurable, micro-browser framework based on the
39 WebKit web content engine and the GTK+ toolkit. It is very fast,
40 extensible by Lua.
41
42 %description -l hu.UTF-8
43 luakit egy magas szinten konfigurálható, micro-böngésző keretrendszer
44 WebKit motorral és GTK+ grafikus felületettel. Nagyon gyors, és Lua
45 nyelven bővíthető.
46
47 %description -l pl.UTF-8
48 luakit jest wysoko konfigurowalnym frameworkiem mikro-przeglądarki
49 opartym na silniku webowym WebKit oraz GTK+. Jest szybki i
50 rozszeezalny przez Lua.
51
52 %prep
53 %if %{without git}
54 %setup -qc
55 mv mason-larobina-%{name}-*/* .
56 %patch0 -p1
57 %else
58 %setup -qcT
59 git clone -b %{git_branch} %{git_url} .
60 %{!?luakit_skip_patches:
61 %patch0 -p1
62 }
63 %endif
64
65 %build
66 CFLAGS="%{rpmcflags}" \
67 LDFLAGS="%{rpmldflags}" \
68 %{__make} \
69         PREFIX=%{_prefix}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} install \
74         PREFIX=%{_prefix} \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS COPYING PATCHES README.md
85
86 %dir %{_sysconfdir}/xdg/luakit
87 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/luakit/*.lua
88 %attr(755,root,root) %{_bindir}/luakit
89 %{_datadir}/luakit
90 %{_pixmapsdir}/luakit.png
91 %{_mandir}/man1/luakit.1*
92 %{_desktopdir}/luakit.desktop
This page took 0.050022 seconds and 3 git commands to generate.