]> git.pld-linux.org Git - SPECS.git/blob - luajit.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / luajit.spec
1 # TODO
2 # - x32 not supported by upstream: http://www.freelists.org/post/luajit/Building-luajit202-on-x32,1
3 Summary:        Just-in-Time compiler for Lua
4 Summary(pl.UTF-8):      Kompilator JIT dla języka Lua
5 Name:           luajit
6 Version:        2.0.5
7 Release:        1
8 License:        MIT
9 Group:          Libraries
10 # Source0Download: http://luajit.org/download.html
11 Source0:        http://luajit.org/download/LuaJIT-%{version}.tar.gz
12 # Source0-md5:  48353202cbcacab84ee41a5a70ea0a2c
13 URL:            http://luajit.org/
14 BuildRequires:  sed >= 4.0
15 ExclusiveArch:  %{ix86} %{x8664} %{arm} mips ppc
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         lua_abi         5.1
19
20 %description
21 LuaJIT is a Just-In-Time (JIT) compiler for the Lua programming
22 language.
23
24 %description -l pl.UTF-8
25 LuaJIT to działający w locie (Just-In-Time) kompilator języka Lua.
26
27 %package devel
28 Summary:        Header files for LuaJIT library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LuaJIT
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files for LuaJIT library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki LuaJIT.
38
39 %package static
40 Summary:        Static LuaJIT library
41 Summary(pl.UTF-8):      Statyczna biblioteka LuaJIT
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static LuaJIT library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka LuaJIT.
50
51 %prep
52 %setup -q -n LuaJIT-%{version}
53
54 # preserve timestamps
55 sed -i -e '/install -m/s/-m/-p -m/' Makefile
56
57 %build
58 # Q= - enable verbose output
59 # E= @: - disable @echo messages
60 # NOTE: we use amalgamated build as per documentation suggestion doc/install.html
61 %{__make} \
62         PREFIX=%{_prefix} \
63         MULTILIB=%{_lib} \
64         CC="%{__cc}" \
65         CCOPT="%{rpmcflags} -fomit-frame-pointer" \
66         CCOPT_x86= \
67         MULTILIB=%{_lib} \
68         E="@:" \
69         Q= \
70         amalg
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT \
76         PREFIX=%{_prefix} \
77         MULTILIB=%{_lib} \
78         LDCONFIG="/sbin/ldconfig -n"
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc COPYRIGHT README
89 %attr(755,root,root) %{_bindir}/luajit
90 %attr(755,root,root) %{_bindir}/luajit-%{version}
91 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so.*.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libluajit-%{lua_abi}.so.2
93 %{_datadir}/luajit-%{version}
94 %{_mandir}/man1/luajit.1*
95 # lua module dirs (shared with lua interpreters)
96 %dir %{_libdir}/lua
97 %dir %{_libdir}/lua/%{lua_abi}
98 %dir %{_datadir}/lua
99 %dir %{_datadir}/lua/%{lua_abi}
100
101 %files devel
102 %defattr(644,root,root,755)
103 %doc doc/*
104 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so
105 %{_includedir}/luajit-2.0
106 %{_pkgconfigdir}/luajit.pc
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libluajit-%{lua_abi}.a
This page took 0.276681 seconds and 3 git commands to generate.