]> git.pld-linux.org Git - SPECS.git/blob - litecoin.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / litecoin.spec
1 Summary:        Litecoin is a peer-to-peer currency
2 Summary(pl.UTF-8):      Litecoin - waluta peer-to-peer
3 Name:           litecoin
4 Version:        0.18.1
5 Release:        3
6 License:        MIT
7 Group:          X11/Applications
8 #Sourrce0Download: https://github.com/litecoin-project/litecoin/releases
9 Source0:        https://download.litecoin.org/litecoin-%{version}/src/%{name}-%{version}.tar.gz
10 # Source0-md5:  67af5786635639536e78993b1fc082d0
11 Patch0:         qt-5.15.patch
12 Patch1:         %{name}-univalue.patch
13 URL:            http://www.litecoin.org/
14 BuildRequires:  Qt5Core-devel >= 5.4
15 BuildRequires:  Qt5DBus-devel >= 5.4
16 BuildRequires:  Qt5Gui-devel >= 5.4
17 BuildRequires:  Qt5Network-devel >= 5.4
18 BuildRequires:  Qt5Widgets-devel >= 5.4
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake
21 BuildRequires:  boost-devel >= 1.49
22 BuildRequires:  db-cxx-devel >= 4.8
23 BuildRequires:  gettext-tools
24 BuildRequires:  libevent-devel >= 2
25 BuildRequires:  libstdc++-devel >= 6:4.7
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  libunivalue-devel >= 1.0.4
28 BuildRequires:  miniupnpc-devel >= 1.5
29 BuildRequires:  openssl-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  python3 >= 1:3.4
32 BuildRequires:  protobuf-devel
33 BuildRequires:  qrencode-devel
34 BuildRequires:  qt5-linguist >= 5.4
35 BuildRequires:  qt5-qmake >= 5.4
36 BuildRequires:  zeromq-devel >= 4
37 Requires:       libunivalue >= 1.0.4
38 Requires:       perl-base
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Litecoin is a peer-to-peer currency. Peer-to-peer means that no
43 central authority issues new money or tracks transactions. These tasks
44 are managed collectively by the network.
45
46 %description -l pl.UTF-8
47 Litecoin to waluta peer-to-peer. Oznacza to, że nie ma centralnej
48 instytucji emitującej nowe pieniądze czy śledzącej transakcje. Zadania
49 te są zarządzane kolektywnie przez sieć.
50
51 %package qt
52 Summary:        Qt-based Litecoin Wallet
53 Summary(pl.UTF-8):      Portfel na litecoiny oparty na Qt
54 Group:          X11/Applications
55 Requires:       %{name} = %{version}-%{release}
56
57 %description qt
58 Qt-based Litecoin Wallet.
59
60 %description qt -l pl.UTF-8
61 Portfel na litecoiny oparty na Qt.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal} -I build-aux/m4
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 cd src/secp256k1
75 %{__libtoolize}
76 %{__aclocal} -I build-aux/m4
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 cd ../..
81 %configure \
82         --disable-bench \
83         --disable-gui-tests \
84         --disable-shared \
85         --disable-silent-rules \
86         --disable-tests \
87         --with-boost \
88         --with-incompatible-bdb \
89         --with-miniupnpc \
90         --with-qrencode \
91         --with-qtdbus \
92         --with-system-univalue
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_datadir}/kde4/services}
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # shared disabled, development packages present in bitcoin.spec and feathercoin.spec
103 %{__rm} -r $RPM_BUILD_ROOT{%{_libdir}/libbitcoinconsensus.*,%{_includedir}/bitcoinconsensus.h,%{_pkgconfigdir}/libbitcoinconsensus.pc}
104
105 # see contrib/rpm/bitcoin.spec
106
107 cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/litecoin-qt.desktop
108 [Desktop Entry]
109 Encoding=UTF-8
110 Name=Litecoin
111 Comment=Litecoin P2P Cryptocurrency
112 Comment[fr]=Litecoin, monnaie virtuelle cryptographique pair à pair
113 Comment[pl]=Litecoin - kryptowaluta P2P
114 Comment[tr]=Litecoin, eşten eşe kriptografik sanal para birimi
115 Exec=litecoin-qt %u
116 Terminal=false
117 Type=Application
118 Icon=bitcoin
119 MimeType=x-scheme-handler/litecoin;
120 Categories=Office;Finance;
121 EOF
122
123 cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/litecoin-qt.protocol
124 [Protocol]
125 exec=litecoin-qt '%u'
126 protocol=litecoin
127 input=none
128 output=none
129 helper=true
130 listing=
131 reading=false
132 writing=false
133 makedir=false
134 deleting=false
135 EOF
136
137 cp -p share/pixmaps/bitcoin.ico $RPM_BUILD_ROOT%{_pixmapsdir}
138 cp -p share/pixmaps/nsis-*.bmp $RPM_BUILD_ROOT%{_pixmapsdir}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %doc COPYING doc/{README,REST-interface,assets-attribution,benchmarking,bips,dependencies,dnsseed-policy,reduce-traffic,release-notes*,shared-libraries,tor,zmq}.md doc/release-notes
146 %attr(755,root,root) %{_bindir}/litecoind
147 %attr(755,root,root) %{_bindir}/litecoin-cli
148 %attr(755,root,root) %{_bindir}/litecoin-wallet
149 %attr(755,root,root) %{_bindir}/litecoin-tx
150 %{_mandir}/man1/litecoin-cli.1*
151 %{_mandir}/man1/litecoin-wallet.1*
152 %{_mandir}/man1/litecoin-tx.1*
153 %{_mandir}/man1/litecoind.1*
154
155 %files qt
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/litecoin-qt
158 %{_datadir}/kde4/services/litecoin-qt.protocol
159 %{_desktopdir}/litecoin-qt.desktop
160 %{_pixmapsdir}/bitcoin.ico
161 %{_pixmapsdir}/nsis-*.bmp
162 %{_mandir}/man1/litecoin-qt.1*
This page took 0.406645 seconds and 3 git commands to generate.