]> git.pld-linux.org Git - SPECS.git/blob - linkchecker.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / linkchecker.spec
1 Summary:        Check HTML documents for broken links
2 Summary(pl.UTF-8):      Sprawdzanie dokumentów HTML pod kątem zerwanych odnośników
3 Name:           linkchecker
4 Version:        4.8
5 Release:        1
6 License:        GPL
7 Group:          Applications/Networking
8 Source0:        http://dl.sourceforge.net/linkchecker/%{name}-%{version}.tar.gz
9 # Source0-md5:  0473839d4c263ffeb98dc44e59026339
10 URL:            http://linkchecker.sourceforge.net/
11 BuildRequires:  pydoc
12 BuildRequires:  python-devel >= 1:2.5
13 BuildRequires:  rpm-pythonprov
14 %pyrequires_eq  python-libs
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Linkchecker features:
19 - recursive checking
20 - multithreading
21 - output in colored or normal text, HTML, SQL, CSV or a sitemap graph
22   in GML or XML.
23 - HTTP/1.1, HTTPS, FTP, mailto:, news:, nntp:, Gopher, Telnet and
24   local file links support
25 - restriction of link checking with regular expression filters for
26   URLs
27 - proxy support
28 - username/password authorization for HTTP and FTP
29 - robots.txt exclusion protocol support
30 - Cookie support
31 - i18n support
32 - a command line interface
33 - a (Fast)CGI web interface (requires HTTP server)
34
35 %description -l pl.UTF-8
36 Cechy linkcheckera:
37 - sprawdzanie rekurencyjne
38 - wielowątkowość
39 - wyjście w kolorowanym lub zwykłym tekście, HTML-u, SQL-u, CSV lub
40   jako mapa serwisu w GML-u lub XML-u
41 - obsługa odnośników HTTP/1.1, HTTPS, FTP, mailto:, news:, nntp:,
42   Gopher, Telnet i lokalnych plików
43 - restrykcje sprawdzania odnośników przy pomocy filtrów URL-i opartych
44   o wyrażenia regularne
45 - obsługa proxy
46 - autoryzacja użytkownik/hasło dla HTTP i FTP
47 - obsługa protokołu wyłączeń robots.txt
48 - obsługa ciasteczek
49 - obsługa wielu języków (i18n)
50 - interfejs z linii poleceń
51 - interfejs WWW (Fast)CGI (wymagający serwera HTTP)
52
53 %prep
54 %setup -q
55
56 %build
57 env CFLAGS="%{rpmcflags}" python setup.py build
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 python setup.py install \
63         --optimize=2 \
64         --root=$RPM_BUILD_ROOT
65
66 # omitted by setup install
67 cp -a build/share/locale $RPM_BUILD_ROOT%{_datadir}
68
69 %py_postclean
70
71 %find_lang %{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files -f %{name}.lang
77 %defattr(644,root,root,755)
78 %doc ChangeLog TODO doc/en/*.{html,css,ico,jpg,png}
79 %attr(755,root,root) %{_bindir}/linkchecker
80 %dir %{py_sitedir}/linkcheck
81 %{py_sitedir}/linkcheck/*.py[co]
82 %dir %{py_sitedir}/linkcheck/HtmlParser
83 %{py_sitedir}/linkcheck/HtmlParser/*.py[co]
84 %attr(755,root,root) %{py_sitedir}/linkcheck/HtmlParser/htmlsax.so
85 %dir %{py_sitedir}/linkcheck/cache
86 %{py_sitedir}/linkcheck/cache/*.py[co]
87 %dir %{py_sitedir}/linkcheck/checker
88 %{py_sitedir}/linkcheck/checker/*.py[co]
89 %dir %{py_sitedir}/linkcheck/configuration
90 %{py_sitedir}/linkcheck/configuration/*.py[co]
91 %dir %{py_sitedir}/linkcheck/director
92 %{py_sitedir}/linkcheck/director/*.py[co]
93 %dir %{py_sitedir}/linkcheck/dns
94 %{py_sitedir}/linkcheck/dns/*.py[co]
95 %dir %{py_sitedir}/linkcheck/dns/rdtypes
96 %{py_sitedir}/linkcheck/dns/rdtypes/*.py[co]
97 %dir %{py_sitedir}/linkcheck/dns/rdtypes/ANY
98 %{py_sitedir}/linkcheck/dns/rdtypes/ANY/*.py[co]
99 %dir %{py_sitedir}/linkcheck/dns/rdtypes/IN
100 %{py_sitedir}/linkcheck/dns/rdtypes/IN/*.py[co]
101 %dir %{py_sitedir}/linkcheck/ftpparse
102 %{py_sitedir}/linkcheck/ftpparse/*.py[co]
103 %attr(755,root,root) %{py_sitedir}/linkcheck/ftpparse/_ftpparse.so
104 %dir %{py_sitedir}/linkcheck/logger
105 %{py_sitedir}/linkcheck/logger/*.py[co]
106 %{py_sitedir}/linkchecker-*.egg-info
107 %dir %{_datadir}/linkchecker
108 %{_datadir}/linkchecker/linkcheckerrc
109 %{_datadir}/linkchecker/logging.conf
110 %dir %{_datadir}/linkchecker/examples
111 %attr(755,root,root) %{_datadir}/linkchecker/examples/*.sh
112 %attr(755,root,root) %{_datadir}/linkchecker/examples/*cgi
113 %{_datadir}/linkchecker/examples/check.js
114 %{_datadir}/linkchecker/examples/index.html
115 %lang(de) %{_datadir}/linkchecker/examples/lc_cgi.html.de
116 %{_datadir}/linkchecker/examples/lc_cgi.html.en
117 %lang(de) %{_datadir}/linkchecker/examples/leer.html.de
118 %{_datadir}/linkchecker/examples/leer.html.en
119 %{_datadir}/linkchecker/examples/linkchecker-completion
120 %{_mandir}/man1/linkchecker.1*
121 %{_mandir}/man5/linkcheckerrc.5*
122 %lang(de) %{_mandir}/de/man1/linkchecker.1*
123 %lang(de) %{_mandir}/de/man5/linkcheckerrc.5*
This page took 0.048382 seconds and 3 git commands to generate.