]> git.pld-linux.org Git - SPECS.git/blob - libtqtinterface.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / libtqtinterface.spec
1 #
2 # Conditional build:
3 %bcond_with             qt4     # Enable Qt4 support (this will disable all Qt3 support)
4
5 %define tde_ver R14.0.0
6 Summary:        Interface and abstraction library for Qt and Trinity
7 Name:           libtqtinterface
8 Version:        4.2.0
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Libraries
12 Source0:        http://tde-mirror.yosemite.net/trinity/releases/%{version}/dependencies/tqtinterface-%{tde_ver}.tar.bz2
13 # Source0-md5:  084cde7fe87789796a9d624b3a8c1663
14 URL:            http://trinity.pearsoncomputing.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  cmake >= 2.8
18 BuildRequires:  libltdl-devel
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRequires:  qt-devel
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Obsoletes:      tqtinterface < 3.5.12-2.1229013
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This package includes libraries that abstract the underlying Qt system
30 from the actual Trinity code, allowing easy, complete upgrades to new
31 versions of Qt.
32
33 It also contains various functions that have been removed from newer
34 versions of Qt, but are completely portable and isolated from other
35 APIs such as Xorg. This allows the Trinity project to efficiently
36 perform certain operations that are infeasible or unneccessarily
37 difficult when using pure Qt4 or above.
38
39 %package devel
40 Summary:        Header files for libtqtinterface library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libtqtinterface
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Obsoletes:      tqtinterface-devel < 3.5.12-2.1229013
45
46 %description devel
47 Header files for libtqtinterface library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libtqtinterface.
51
52 %prep
53 %setup -qc
54 mv dependencies/tqtinterface/* .
55
56 %build
57 install -d build
58 cd build
59 %cmake \
60         -DQT_VERSION=3 \
61         -DQT_INCLUDE_DIR=%{_includedir}/qt \
62         -DQT_LIBRARY_DIR=%{_libdir} \
63         ..
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %{__make} -C build install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 # obsoleted by pkgconfig
73 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtqt.la
74 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtqassistantclient.la
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libtqt.so.*.*.*
85 %ghost %attr(755,root,root) %{_libdir}/libtqt.so.4
86 %attr(755,root,root) %{_libdir}/libtqassistantclient.so.*.*.*
87 %ghost %attr(755,root,root) %{_libdir}/libtqassistantclient.so.4
88
89 %files devel
90 %defattr(644,root,root,755)
91 %doc AUTHORS COPYING README
92 %attr(755,root,root) %{_bindir}/convert_qt_tqt1
93 %attr(755,root,root) %{_bindir}/convert_qt_tqt2
94 %attr(755,root,root) %{_bindir}/convert_qt_tqt3
95 %attr(755,root,root) %{_bindir}/dcopidl-tqt
96 %attr(755,root,root) %{_bindir}/dcopidl2cpp-tqt
97 %attr(755,root,root) %{_bindir}/dcopidlng-tqt
98 %attr(755,root,root) %{_bindir}/mcopidl-tqt
99 %attr(755,root,root) %{_bindir}/moc-tqt
100 %attr(755,root,root) %{_bindir}/tmoc
101 %attr(755,root,root) %{_bindir}/tqt-replace
102 %attr(755,root,root) %{_bindir}/tqt-replace-stream
103 %attr(755,root,root) %{_bindir}/uic-tqt
104 %dir %{_includedir}/tqt
105 %{_includedir}/tqt/tq*.h
106 %dir %{_includedir}/tqt/Qt
107 %dir %{_includedir}/tqt/Qt/*.h
108 %{_pkgconfigdir}/tqt.pc
109 %{_pkgconfigdir}/tqtqui.pc
110 %{_libdir}/libtqt.so
111 %{_libdir}/libtqassistantclient.so
This page took 0.060172 seconds and 3 git commands to generate.