]> git.pld-linux.org Git - SPECS.git/blob - libssh2.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / libssh2.spec
1 Summary:        Library implementing the SSH2 protocol
2 Summary(pl.UTF-8):      Biblioteka implementująca protokół SSH2
3 Name:           libssh2
4 Version:        1.9.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 Source0:        https://www.libssh2.org/download/%{name}-%{version}.tar.gz
9 # Source0-md5:  1beefafe8963982adc84b408b2959927
10 URL:            https://libssh2.org/
11 BuildRequires:  autoconf >= 2.57
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  openssl-devel
15 BuildRequires:  zlib-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 libssh2 is a C library implementing the SSH2 protocol according to
20 Internet Draft specifications SECSH-TRANS(22), SECSH-USERAUTH(25),
21 SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06),
22 SECSH-DHGEX(04), and SECSH-NUMBERS(10).
23
24 Supported Ciphers:
25 - aes256-ctr, aes192-ctr, aes128-ctr,
26 - aes256-cbc (aka rijndael-cbc@lysator.liu.se), aes192-cbc, aes128-cbc
27 - 3des-cbc
28 - blowfish-cbc
29 - cast128-cbc
30 - arcfour, arcfour128
31 - none
32
33 Supported Key Exchange Methods:
34 - diffie-hellman-group1-sha1
35 - diffie-hellman-group14-sha1
36 - diffie-hellman-group-exchange-sha1
37 - diffie-hellman-group-exchange-sha256
38
39 Supported Hostkey Types:
40 - ssh-rsa
41 - ssh-dss
42
43 Supported Compression Methods:
44 - zlib, zlib@openssh.com
45 - none
46
47 Supported Message Authentication Codes:
48 - hmac-sha2-256, hmac-sha2-512
49 - hmac-sha1, hmac-sha1-96
50 - hmac-md5, hmac-md5-96
51 - hmac-ripemd160 (hmac-ripemd160@openssh.com)
52 - none
53
54 %description -l pl.UTF-8
55 libssh2 to biblioteka C implementująca protokół SSH2 zgodnie ze
56 specyfikacjami Internet Draft SECSH-TRANS(22), SECSH-USERAUTH(25),
57 SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06),
58 SECSH-DHGEX(04), and SECSH-NUMBERS(10).
59
60 Obsługiwane szyfry:
61 - aes256-ctr, aes192-ctr, aes128-ctr,
62 - aes256-cbc (znany też jako rijndael-cbc@lysator.liu.se), aes192-cbc,
63   aes128-cbc
64 - 3des-cbc
65 - blowfish-cbc
66 - cast128-cbc
67 - arcfour, arcfour128
68 - none
69
70 Obsługiwane metody wymiany kluczy:
71 - diffie-hellman-group1-sha1
72 - diffie-hellman-group14-sha1
73 - diffie-hellman-group-exchange-sha1
74 - diffie-hellman-group-exchange-sha256
75
76 Obsługiwane rodzaju kluczy hosta:
77 - ssh-rsa
78 - ssh-dss
79
80 Obsługiwane metody kompresji:
81 - zlib
82 - none
83
84 Obsługiwane kody uwierzytelniania wiadomości:
85 - hmac-sha2-256, hmac-sha2-512
86 - hmac-sha1, hmac-sha1-96
87 - hmac-md5, hmac-md5-96
88 - hmac-ripemd160 (hmac-ripemd160@openssh.com)
89 - none
90
91 %package devel
92 Summary:        Header files for libssh2 library
93 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libssh2
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       openssl-devel
97 Requires:       zlib-devel
98
99 %description devel
100 Header files for libssh2 library.
101
102 %description devel -l pl.UTF-8
103 Pliki nagłówkowe biblioteki libssh2.
104
105 %package static
106 Summary:        Static libssh2 library
107 Summary(pl.UTF-8):      Biblioteka statyczna libssh2
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Static libssh2 library.
113
114 %description static -l pl.UTF-8
115 Biblioteka statyczna libssh2.
116
117 %prep
118 %setup -q
119
120 %build
121 %{__libtoolize}
122 %{__aclocal} -I m4
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 %configure \
127         --disable-silent-rules \
128         --with-openssl=%{_prefix}
129 # AC_LIB_HAVE_LINKFLAGS adds unwanted -L/usr/lib to each LTLIB* - override it
130 %{__make} \
131         LTLIBSSL="-lssl -lcrypto" \
132         LTLIBZ="-lz"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc COPYING NEWS README RELEASE-NOTES docs/{AUTHORS,BINDINGS,TODO}
149 %attr(755,root,root) %{_libdir}/libssh2.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libssh2.so.1
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libssh2.so
155 %{_libdir}/libssh2.la
156 %{_includedir}/libssh2*.h
157 %{_mandir}/man3/libssh2_*.3*
158 %{_pkgconfigdir}/libssh2.pc
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/libssh2.a
This page took 0.543525 seconds and 3 git commands to generate.