]> git.pld-linux.org Git - SPECS.git/blob - libsbsms2.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / libsbsms2.spec
1 #
2 # Conditional build:
3 %bcond_with     sse     # use SSE optimizations
4 #
5 %ifarch pentium3 pentium4 %{x8664}
6 %define with_sse        1
7 %endif
8 Summary:        C++ library for high quality time stretching and pitch scaling
9 Summary(pl.UTF-8):      Biblioteka C++ do wysokiej jakości zmiany szybkości i wysokości dźwięku
10 Name:           libsbsms2
11 Version:        2.2.0
12 Release:        1
13 License:        GPL v2
14 Group:          Libraries
15 #Source0Download: https://github.com/claytonotey/releases
16 Source0:        https://github.com/claytonotey/libsbsms/archive/%{version}/libsbsms-%{version}.tar.gz
17 # Source0-md5:  516b6d4dbd9f991c9e316cc6e0131f98
18 Patch0:         libsbsms-opts.patch
19 Patch1:         libsbsms-gcc.patch
20 Patch2:         libsbsms-link.patch
21 URL:            https://github.com/claytonotey/libsbsms
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake >= 1.5
24 BuildRequires:  libmad-devel
25 BuildRequires:  libsndfile-devel >= 1.0.2
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  pkgconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 libsbsms is a library for high quality time and pitch scale
33 modification. It uses octave subband sinusoidal modeling.
34
35 %description -l pl.UTF-8
36 libsbsms to biblioteka do wysokiej jakości modyfikowania szybkości i
37 wysokości dźwięku. Wykorzystuje modelowanie sinusoidalne.
38
39 %package devel
40 Summary:        Header files for libsbsms 2 library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsbsms 2
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libstdc++-devel
45 Conflicts:      libsbsms-devel < 2
46
47 %description devel
48 Header files for libsbsms 2 library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki libsbsms 2.
52
53 %package static
54 Summary:        Static libsbsms 2 library
55 Summary(pl.UTF-8):      Statyczna biblioteka libsbsms 2
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58 Conflicts:      libsbsms-static < 2
59
60 %description static
61 Static libsbsms 2 library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka libsbsms 2.
65
66 %prep
67 %setup -q -n libsbsms-%{version}
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure \
79         --enable-multithreaded \
80         --enable-shared \
81         %{!?with-sse:--disable-sse}
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS README.md TODO
99 %attr(755,root,root) %{_libdir}/libsbsms.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libsbsms.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libsbsms.so
105 %{_libdir}/libsbsms.la
106 %{_includedir}/sbsms.h
107 %{_pkgconfigdir}/sbsms.pc
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libsbsms.a
This page took 0.37741 seconds and 3 git commands to generate.