]> git.pld-linux.org Git - SPECS.git/blob - librevenge.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / librevenge.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  gdb             # GDB pretty printers
5
6 Summary:        Library for generic document converters
7 Summary(pl.UTF-8):      Biblioteka dla ogólnych konwerterów dokumentów
8 Name:           librevenge
9 Version:        0.0.4
10 Release:        2
11 License:        MPL v2.0 or LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libwpd/%{name}-%{version}.tar.xz
14 # Source0-md5:  2677cf97716c699146f999575ac0147d
15 URL:            https://sourceforge.net/p/libwpd/wiki/librevenge/
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  boost-devel >= 1.20
19 BuildRequires:  cppunit-devel
20 BuildRequires:  doxygen
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  pkgconfig
24 %{?with_gdb:BuildRequires:      python-modules}
25 BuildRequires:  rpmbuild(macros) >= 1.234
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 librevenge is a base library for writing document import filters. It
33 has interfaces for text documents, vector graphics, spreadsheets and
34 presentations.
35
36 %description -l pl.UTF-8
37 librevenge to biblioteka podstawowa do pisania filtrów importujących
38 dokumenty. Zawiera interfejsy dla dokumentów tekstowych, grafiki
39 wektorowej, arkuszy kalkulacyjnych oraz prezentacji.
40
41 %package devel
42 Summary:        Header files for librevenge library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki librevenge
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libstdc++-devel
47
48 %description devel
49 Header files for librevenge library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki librevenge.
53
54 %package static
55 Summary:        Static librevenge library
56 Summary(pl.UTF-8):      Statyczna biblioteka librevenge
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static librevenge library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka librevenge.
65
66 %package apidocs
67 Summary:        API documentation for librevenge library
68 Summary(pl.UTF-8):      Dokumentacja API biblioteki librevenge
69 Group:          Documentation
70 BuildArch:      noarch
71
72 %description apidocs
73 API documentation for librevenge library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki librevenge.
77
78 %package gdb
79 Summary:        GDB Python pretty printers for librevenge types
80 Summary(pl.UTF-8):      Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge
81 Group:          Development/Debuggers
82 Requires:       gdb
83
84 %description gdb
85 GDB Python pretty printers for librevenge types.
86
87 %description gdb -l pl.UTF-8
88 Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge.
89
90 %prep
91 %setup -q
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         %{?with_gdb:--enable-pretty-printers} \
101         %{?with_static_libs:--enable-static} \
102         --disable-werror \
103         --disable-silent-rules
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librevenge-*.la
114
115 %if %{with gdb}
116 %py_comp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
117 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
118 %py_postclean %{_datadir}/librevenge/python/librevenge
119 %endif
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog NEWS README
130 %attr(755,root,root) %{_libdir}/librevenge-0.0.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/librevenge-0.0.so.0
132 %attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/librevenge-generators-0.0.so.0
134 %attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/librevenge-stream-0.0.so.0
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/librevenge-0.0.so
140 %attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so
141 %attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so
142 %{_includedir}/librevenge-0.0
143 %{_pkgconfigdir}/librevenge-0.0.pc
144 %{_pkgconfigdir}/librevenge-generators-0.0.pc
145 %{_pkgconfigdir}/librevenge-stream-0.0.pc
146
147 %if %{with static_libs}
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/librevenge-0.0.a
151 %{_libdir}/librevenge-generators-0.0.a
152 %{_libdir}/librevenge-stream-0.0.a
153 %endif
154
155 %files apidocs
156 %defattr(644,root,root,755)
157 %doc docs/doxygen/html/*
158
159 %if %{with gdb}
160 %files gdb
161 %defattr(644,root,root,755)
162 %{_datadir}/gdb/auto-load/%{_libdir}/librevenge-0.0.py
163 %{_datadir}/gdb/auto-load/%{_libdir}/librevenge-stream-0.0.py
164 %dir %{_datadir}/librevenge
165 %{_datadir}/librevenge/python
166 %endif
This page took 0.230402 seconds and 3 git commands to generate.