]> git.pld-linux.org Git - SPECS.git/blob - libqxt.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / libqxt.spec
1 # NOTE
2 # - no longer maintained
3 Summary:        Qt extension library
4 Summary(pl.UTF-8):      Biblioteka rozszerzeń Qt
5 Name:           libqxt
6 Version:        0.6.2
7 Release:        1
8 License:        CPL v1.0 or LGPL v2.1
9 Group:          Libraries
10 Source0:        https://bitbucket.org/libqxt/libqxt/get/v%{version}.tar.bz2?/%{name}-%{version}.tar.bz2
11 # Source0-md5:  a859a1757dc0aaf010df1a0783e3e001
12 Patch0:         %{name}-linking.patch
13 Patch1:         %{name}-db.patch
14 URL:            https://bitbucket.org/libqxt/libqxt/wiki/Home
15 BuildRequires:  QtCore-devel >= 4.3
16 BuildRequires:  QtDesigner-devel >= 4.3
17 BuildRequires:  QtGui-devel >= 4.3
18 BuildRequires:  QtNetwork-devel >= 4.3
19 BuildRequires:  QtScript-devel >= 4.3
20 BuildRequires:  QtSql-devel >= 4.3
21 BuildRequires:  avahi-compat-libdns_sd-devel
22 BuildRequires:  avahi-devel
23 BuildRequires:  db-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  qt4-build >= 4.3
27 BuildRequires:  qt4-qmake >= 4.3
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  which
30 BuildRequires:  xorg-lib-libXrandr-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt4_datadir     %{_datadir}/qt4
34 %define         qt4_plugindir   %{_libdir}/qt4/plugins
35
36 %description
37 LibQxt, an extension library for Qt, provides a suite of
38 cross-platform utility classes to add functionality not readily
39 available in the Qt toolkit.
40
41 %description
42 LibQxt to biblioteka rozszeszeń Qt, udostępniająca zbiór
43 wieloplatformowych klas narzędziowych dodających funkcje nie
44 dostępne w łatwy sposób w bibliotekach Qt.
45
46 %package devel
47 Summary:        Development files for Qxt libraries
48 Summary(pl.UTF-8):      Pliki programistyczne bibliotek Qxt
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       QtCore-devel >= 4.3
52 Requires:       QtGui-devel >= 4.3
53 Requires:       QtNetwork-devel >= 4.3
54 Requires:       QtSql-devel >= 4.3
55 Requires:       avahi-compat-libdns_sd-devel
56 Requires:       avahi-devel
57 Requires:       db-devel
58 Requires:       libstdc++-devel
59 Requires:       qt4-qmake >= 4.3
60
61 %description devel
62 This package contains the header files for developing applications
63 that use LibQxt.
64
65 %description devel -l pl.UTF-8
66 Ten pakiet  zawiera pliki nagłówkowe do tworzenia aplikacji
67 wykorzystujących libQxt.
68
69 %package -n QtDesigner-plugin-qxt
70 Summary:        QtDesigner plugin to support Qxt libraries
71 Summary(pl.UTF-8):      Wtyczka QtDesignera wspomagająca korzystanie z bibliotek Qxt
72 Group:          Development/Tools
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       QtDesigner >= 4.3
75
76 %description -n QtDesigner-plugin-qxt
77 QtDesigner plugin to support Qxt libraries.
78
79 %description -n QtDesigner-plugin-qxt -l pl.UTF-8
80 Wtyczka QtDesignera wspomagająca korzystanie z bibliotek Qxt.
81
82 %prep
83 %setup -q -n libqxt-libqxt-dadc327c2a6a
84 %patch0 -p1
85 %patch1 -p1
86
87 # We don't want rpath
88 sed -i '/-rpath/d' src/qxtlibs.pri
89
90 %build
91 # Does not use GNU configure
92 ./configure -verbose \
93         -qmake-bin qmake-qt4 \
94         -prefix %{_prefix} \
95         -libdir %{_libdir}
96
97 %{__make} -j1
98 #%{__make} docs
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 %{__make} install \
103         INSTALL_ROOT=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so.0.6
106
107 # We are installing these to the proper location
108 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS CHANGES *.txt LICENSE README
119 %attr(755,root,root) %{_libdir}/libQxtBerkeley.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libQxtBerkeley.so.0
121 %attr(755,root,root) %{_libdir}/libQxtCore.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libQxtCore.so.0
123 %attr(755,root,root) %{_libdir}/libQxtGui.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libQxtGui.so.0
125 %attr(755,root,root) %{_libdir}/libQxtNetwork.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libQxtNetwork.so.0
127 %attr(755,root,root) %{_libdir}/libQxtSql.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libQxtSql.so.0
129 %attr(755,root,root) %{_libdir}/libQxtWeb.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libQxtWeb.so.0
131 %attr(755,root,root) %{_libdir}/libQxtZeroconf.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libQxtZeroconf.so.0
133
134 %files devel
135 %defattr(644,root,root,755)
136 %doc examples
137 #%doc doc/html
138 %attr(755,root,root) %{_libdir}/libQxtBerkeley.so
139 %attr(755,root,root) %{_libdir}/libQxtCore.so
140 %attr(755,root,root) %{_libdir}/libQxtGui.so
141 %attr(755,root,root) %{_libdir}/libQxtNetwork.so
142 %attr(755,root,root) %{_libdir}/libQxtSql.so
143 %attr(755,root,root) %{_libdir}/libQxtWeb.so
144 %attr(755,root,root) %{_libdir}/libQxtZeroconf.so
145 %{_includedir}/QxtBerkeley
146 %{_includedir}/QxtCore
147 %{_includedir}/QxtGui
148 %{_includedir}/QxtNetwork
149 %{_includedir}/QxtSql
150 %{_includedir}/QxtWeb
151 %{_includedir}/QxtZeroconf
152 %{qt4_datadir}/mkspecs/features/qxt*.prf
153
154 %files -n QtDesigner-plugin-qxt
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{qt4_plugindir}/designer/libQxtDesignerPlugins.so
This page took 0.142555 seconds and 3 git commands to generate.