]> git.pld-linux.org Git - SPECS.git/blob - libpipeline.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / libpipeline.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library build
4 #
5 Summary:        A pipeline manipulation library
6 Summary(pl.UTF-8):      Biblioteka operacji na linii potoków
7 Name:           libpipeline
8 Version:        1.5.3
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Libraries
12 Source0:        http://download.savannah.gnu.org/releases/libpipeline/%{name}-%{version}.tar.gz
13 # Source0-md5:  dad443d0911cf9f0f1bd90a334bc9004
14 URL:            http://libpipeline.nongnu.org/
15 BuildRequires:  check-devel >= 0.9.4
16 BuildRequires:  libtool >= 2:2
17 BuildRequires:  pkgconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 libpipeline is a C library for setting up and running pipelines of
22 processes, without needing to involve shell command-line parsing which
23 is often error-prone and insecure. This alleviates programmers of the
24 need to laboriously construct pipelines using lower-level primitives
25 such as fork(2) and execve(2).
26
27 %description -l pl.UTF-8
28 libpipeline to biblioteka C do ustanawiania i uruchamiania linii
29 potoków procesów bez potrzeby wykonywania analizy linii poleceń, która
30 jest zwykle błędogenna i niebezpieczna. Ogranicza konieczność
31 pracochłonnego tworzenia linii potoków przez programistów przy użyciu
32 niskopoziomowych wywołań, takich jak fork(2) i execve(2).
33
34 %package devel
35 Summary:        Header file for pipeline manipulation library
36 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki operacji na linii potoków
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 libpipeline-devel contains the header file needed to develop programs
42 that use libpipeline library.
43
44 %description devel -l pl.UTF-8
45 Ten pakiet zawiera plik nagłówkowy potrzebny do tworzenia programów
46 wykorzystujących bibliotekę libpipeline.
47
48 %package static
49 Summary:        Static libpipeline library
50 Summary(pl.UTF-8):      Statyczna biblioteka libpipeline
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static libpipeline library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka libpipeline.
59
60 %prep
61 %setup -q
62
63 %build
64 %configure \
65         --disable-silent-rules \
66         %{?with_static_libs:--enable-static}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %{__make} install \
72         prefix=%{_prefix} \
73         INSTALL='install -p' \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 # obsoleted by pkg-config
77 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libpipeline.la
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc ChangeLog NEWS README TODO
88 %attr(755,root,root) %{_libdir}/libpipeline.so.*.*.*
89 %attr(755,root,root) %ghost %{_libdir}/libpipeline.so.1
90
91 %files devel
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_libdir}/libpipeline.so
94 %{_includedir}/pipeline.h
95 %{_mandir}/man3/libpipeline.3*
96 %{_mandir}/man3/pipecmd_*.3*
97 %{_mandir}/man3/pipeline_*.3*
98 %{_pkgconfigdir}/libpipeline.pc
99
100 %if %{with static_libs}
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libpipeline.a
104 %endif
This page took 0.128579 seconds and 3 git commands to generate.