]> git.pld-linux.org Git - SPECS.git/blob - libofx.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / libofx.spec
1 Summary:        LibOFX library that allows applications to support OFX command responses
2 Summary(pl.UTF-8):      Biblioteka LibOFX pozwalająca aplikacjom obsługiwać odpowiedzi na polecenia OFX
3 Name:           libofx
4 Version:        0.9.10
5 Release:        1
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/libofx/%{name}-%{version}.tar.gz
9 # Source0-md5:  adfa83a08d76b047f89a82d5b484f79b
10 Patch0:         %{name}-system-wide-treehh.patch
11 Patch1:         stdc++.patch
12 Patch2:         %{name}-flags.patch
13 URL:            http://libofx.sourceforge.net/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake
16 BuildRequires:  curl-devel >= 7.9.7
17 BuildRequires:  help2man
18 BuildRequires:  libtool >= 2:1.5
19 BuildRequires:  libxml++2-devel >= 2.6
20 BuildRequires:  opensp-devel
21 BuildRequires:  tree.hh
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is the LibOFX library. It is a API designed to allow applications
26 to very easily support OFX command responses, usually provided by
27 financial institutions. See http://www.ofx.net/ofx/default.asp for
28 details and specification. LibOFX is based on the excellent OpenSP
29 library written by James Clark, and now part of the OpenJADE project
30 (http://openjade.sourceforge.net/). LibOFX is written in C++, but
31 provides a C style interface usable transparently from both C and C++
32 using a single include file.
33
34 %description -l pl.UTF-8
35 Ten pakiet zawiera bibliotekę LibOFX. Jest to API zaprojektowane aby
36 umożliwić aplikacjom w prosty sposób obsługiwać odpowiedzi na
37 polecenia OFX, zwykle udostępniane przez instytucje finansowe.
38 Szczegóły oraz specyfikację można znaleźć na stronie
39 http://www.ofx.net/ofx/default.asp. LibOFX jest oparta na świetnej
40 bibliotece OpenSP napisanej przez Jamesa Clarka, będącej teraz częścią
41 projektu OpenJADE (http://openjade.sourceforge.net/). LibOFX jest
42 napisana w C++, ale udostępnia interfejs w C, którego można używać w
43 sposób przezroczysty z poziomu C i C++ przy użyciu tego samego pliku
44 nagłówkowego.
45
46 %package devel
47 Summary:        Header files for LibOFX library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibOFX
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       opensp-devel
52
53 %description devel
54 Header files for developing programs using LibOFX.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe do tworzenia programów z użyciem LibOFX.
58
59 %package static
60 Summary:        Static version LibOFX library
61 Summary(pl.UTF-8):      Biblioteka statyczna LibOFX
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static LibOFX library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka LibOFX.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %{__rm} lib/tree.hh
77
78 %build
79 %{__libtoolize}
80 %{__aclocal} -I m4
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 # C++ 11 is required by tree.hh 3+ and libxml++ 2.40+
85 CXXFLAGS="%{rpmcxxflags} -std=c++0x"
86 %configure \
87         --with-opensp-libs=%{_libdir}
88
89 %{__make} -j1
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # obsoleted by pkg-config
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libofx.la
99 # packaged as %doc
100 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libofx
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README
111 %attr(755,root,root) %{_bindir}/ofx2qif
112 %attr(755,root,root) %{_bindir}/ofxconnect
113 %attr(755,root,root) %{_bindir}/ofxdump
114 %attr(755,root,root) %{_libdir}/libofx.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libofx.so.6
116 %{_datadir}/libofx
117 %{_mandir}/man1/ofxconnect.1*
118 %{_mandir}/man1/ofxdump.1*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %doc doc/html
123 %attr(755,root,root) %{_libdir}/libofx.so
124 %{_includedir}/libofx
125 %{_pkgconfigdir}/libofx.pc
126
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libofx.a
This page took 0.196359 seconds and 3 git commands to generate.