]> git.pld-linux.org Git - SPECS.git/blob - libjingle.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / libjingle.spec
1 %define         apiver  0.6
2 Summary:        Google Talk's implementation of Jingle and Jingle-Audio
3 Summary(pl.UTF-8):      Implementacja Jingle i Jingle-Audio programu Google Talk
4 Name:           libjingle
5 Version:        0.6.14
6 Release:        6
7 License:        BSD
8 Group:          Applications/Communication
9 #Source0Download: http://code.google.com/p/libjingle/downloads/list
10 Source0:        http://libjingle.googlecode.com/files/%{name}-%{version}.zip
11 # Source0-md5:  b3906436df810620ced9ea7ec300799d
12 # fedora patches
13 # fedora loves to keep patch for every libjingle version, like they're not using VCS
14 # awk -vf=~/fc/libjingle '/^Patch/{s=d=$NF;sub(/libjingle-[0-9]+\.[0-9]+\.[0-9]+-/, "", d); printf("cp %s/%s %s\n", f, s, d)}' ~/fc/libjingle/libjingle.spec | sh
15 Patch0:         build-sanity.patch
16 Patch1:         C-linkage-fix.patch
17 Patch2:         NULL-fix.patch
18 Patch3:         statfix.patch
19 Patch4:         uint32-fix.patch
20 Patch5:         timefix.patch
21 Patch6:         unixfilesystemfix.patch
22 Patch7:         system-expat.patch
23 Patch9:         devicemanager-fix.patch
24 Patch10:        v4llookup-fix.patch
25 Patch11:        fixconflict.patch
26 Patch14:        config-linux.patch
27 Patch16:        compilefix.patch
28 Patch17:        size_t.patch
29 Patch18:        fixmacro.patch
30 Patch19:        %{name}-srtp2.patch
31 Patch20:        unistd.patch
32 Patch21:        %{name}-sysmacros.patch
33 Patch22:        %{name}-openssl-1.1.patch
34 # /fedora patches
35 Patch100:       bashism.patch
36 Patch101:       time-timeutils.patch
37 URL:            https://developers.google.com/talk/libjingle/developer_guide
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf >= 2.50
40 BuildRequires:  automake
41 BuildRequires:  expat-devel >= 1.95
42 BuildRequires:  gtk+2-devel >= 2.0
43 BuildRequires:  webrtc-libilbc-devel
44 BuildRequires:  libsrtp2-devel >= 2.0
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool
47 BuildRequires:  openssl-devel >= 0.9.7g
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(macros) >= 1.583
50 BuildRequires:  udev-devel
51 BuildRequires:  unzip
52 BuildRequires:  xorg-lib-libXcomposite-devel
53 BuildRequires:  xorg-lib-libXrender-devel
54 Requires:       openssl >= 0.9.7g
55 ExclusiveArch:  %{ix86} %{x8664} %{arm} x32
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 # TODO: check if something can be fixed
59 %define         skip_post_check_so      libjinglebase.so.*.*.* libjinglexmpp.so.1.0.0 libjinglep2pbase.so.1.0.0 libjinglep2pclient.so.1.0.0 libjinglesessiontunnel.so.1.0.0 libjinglesessionphone.so.1.0.0 libjinglesound.so.1.0.0
60
61 %description
62 Libjingle is a set of C++ components provided by Google to
63 interoperate with Google Talk's peer-to-peer and voice calling
64 capabilities. The package includes Google's implementation of Jingle
65 and Jingle-Audio, two proposed extensions to the XMPP standard that
66 are currently available in experimental draft form.
67
68 In addition to enabling interoperability with Google Talk, there are
69 several general purpose components in the library such as the P2P
70 stack which can be used to build a variety of communication and
71 collaboration applications.
72
73 %description -l pl.UTF-8
74 libjingle to zestaw komponentów C++ udostępnionych przez Google do
75 współpracy z usługami peer-to-peer i voice Google Talk. Pakiet zawiera
76 implementacje Google Jingle i Jingle-Audio - dwóch proponowanych
77 rozszerzeń standardu XMPP, aktualnie dostępnych w postaci
78 eksperymentalnego szkicu.
79
80 Oprócz umożliwienia współpracy z Google Talk w bibliotece dostępne
81 jest kilka komponentów ogólnego przeznaczenia, takich jak stos P2P,
82 który może być wykorzystany do tworzenia różnych aplikacji do
83 komunikacji i współpracy.
84
85 %package devel
86 Summary:        Header files for libjingle library
87 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libjingle
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       expat-devel
91 Requires:       gtk+2-devel >= 2.0
92 Requires:       libsrtp2-devel
93 Requires:       libstdc++-devel
94 Requires:       openssl-devel >= 0.9.7g
95 Requires:       xorg-lib-libXrender-devel
96
97 %description devel
98 This package provides the necessary header files allow you to compile
99 applications using libjingle.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe potrzebne do programowania z użyciem libjingle.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109 %patch3 -p1
110 %patch4 -p1
111 %patch5 -p1
112 %patch6 -p1
113 %patch7 -p1
114 %patch9 -p1
115 %patch10 -p1
116 %patch11 -p1
117 %patch14 -p1
118 %patch16 -p1
119 %patch17 -p1
120 %patch18 -p1
121 %patch19 -p1
122 %patch20 -p1
123 %patch21 -p1
124 %patch22 -p1
125
126 %patch100 -p1
127 %patch101 -p1
128 %{__rm} talk/base/time.h
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         --disable-static
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 # .pc exists so remove .la
146 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc AUTHORS COPYING README
157 %attr(755,root,root) %{_bindir}/relayserver
158 %attr(755,root,root) %{_bindir}/stunserver
159 %attr(755,root,root) %{_libdir}/libjinglebase.so.*.*.*
160 %ghost %{_libdir}/libjinglebase.so.1
161 %attr(755,root,root) %{_libdir}/libjinglep2pbase.so.*.*.*
162 %ghost %{_libdir}/libjinglep2pbase.so.1
163 %attr(755,root,root) %{_libdir}/libjinglep2pclient.so.*.*.*
164 %ghost %{_libdir}/libjinglep2pclient.so.1
165 %attr(755,root,root) %{_libdir}/libjinglesessionphone.so.*.*.*
166 %ghost %{_libdir}/libjinglesessionphone.so.1
167 %attr(755,root,root) %{_libdir}/libjinglesessiontunnel.so.*.*.*
168 %ghost %{_libdir}/libjinglesessiontunnel.so.1
169 %attr(755,root,root) %{_libdir}/libjinglesound.so.*.*.*
170 %ghost %{_libdir}/libjinglesound.so.1
171 %attr(755,root,root) %{_libdir}/libjinglexmllite.so.*.*.*
172 %ghost %{_libdir}/libjinglexmllite.so.1
173 %attr(755,root,root) %{_libdir}/libjinglexmpp.so.*.*.*
174 %ghost %{_libdir}/libjinglexmpp.so.1
175
176 %files devel
177 %defattr(644,root,root,755)
178 %{_libdir}/libjinglebase.so
179 %{_libdir}/libjinglep2pbase.so
180 %{_libdir}/libjinglep2pclient.so
181 %{_libdir}/libjinglesessionphone.so
182 %{_libdir}/libjinglesessiontunnel.so
183 %{_libdir}/libjinglesound.so
184 %{_libdir}/libjinglexmllite.so
185 %{_libdir}/libjinglexmpp.so
186 %{_includedir}/libjingle-%{apiver}
187 %{_pkgconfigdir}/jinglebase-%{apiver}.pc
188 %{_pkgconfigdir}/jinglep2p-%{apiver}.pc
189 %{_pkgconfigdir}/jinglesessionphone-%{apiver}.pc
190 %{_pkgconfigdir}/jinglesessiontunnel-%{apiver}.pc
This page took 0.122807 seconds and 3 git commands to generate.