]> git.pld-linux.org Git - SPECS.git/blob - libgpg-error.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / libgpg-error.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Library libgpg-error
6 Summary(pl.UTF-8):      Biblioteka libgpg-error
7 Name:           libgpg-error
8 Version:        1.42
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2
13 # Source0-md5:  133fed221ba8f63f5842858a1ff67cb3
14 Patch0:         %{name}-info.patch
15 URL:            http://www.gnupg.org/related_software/libgpg-error/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.14
18 BuildRequires:  gettext-tools >= 0.19.3
19 BuildRequires:  libtool >= 2:2.2.6
20 BuildRequires:  texinfo
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 libgpg-error is a library that defines common error values for all
25 GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
26 libgcrypt, pinentry, SmartCard Daemon and possibly more in the future.
27
28 %description -l pl.UTF-8
29 libgpg-error jest biblioteką definiującą wartości błędów wspólne dla
30 komponentów GnuPG. Są wśród nich GPG, GPGSM, GPGME, GPG-Agent,
31 libgcrypt, pinentry, SmartCard Daemon i inne - w przyszłości.
32
33 %package devel
34 Summary:        Header files for libgpg-error
35 Summary(pl.UTF-8):      Pliki nagłówkowe dla libgpg-error
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 libgpg-error is a library that defines common error values for all
41 GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
42 libgcrypt, pinentry, SmartCard Daemon and possibly more in the future.
43
44 This package contains the header files needed to develop programs that
45 use these libgpg-error.
46
47 %description devel -l pl.UTF-8
48 libgpg-error jest biblioteką definiującą wartości błędów wspólne dla
49 komponentów GnuPG. Są wśród nich GPG, GPGSM, GPGME, GPG-Agent,
50 libgcrypt, pinentry, SmartCard Daemon i inne - w przyszłości.
51
52 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
53 używających biblioteki libgpg-error.
54
55 %package static
56 Summary:        Static version of libgpg-error library
57 Summary(pl.UTF-8):      Statyczna wersja biblioteki libgpg-error
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 libgpg-error is a library that defines common error values for all
63 GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
64 libgcrypt, pinentry, SmartCard Daemon and possibly more in the future.
65
66 This package contains the static libgpg-error libraries.
67
68 %description static -l pl.UTF-8
69 libgpg-error jest biblioteką definiującą wartości błędów wspólne dla
70 komponentów GnuPG. Są wśród nich GPG, GPGSM, GPGME, GPG-Agent,
71 libgcrypt, pinentry, SmartCard Daemon i inne - w przyszłości.
72
73 Pakiet zawiera statyczne biblioteki libgpg-error.
74
75 %package -n common-lisp-gpg-error
76 Summary:        Common Lisp binding for libgpg-error library
77 Summary(pl.UTF-8):      Wiązania Common Lispa do biblioteki libgpg-error
78 Group:          Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       common-lisp-controller
81
82 %description -n common-lisp-gpg-error
83 Common Lisp binding for libgpg-error library.
84
85 %description -n common-lisp-gpg-error -l pl.UTF-8
86 Wiązania Common Lispa do biblioteki libgpg-error.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %{__rm} po/stamp-po
93
94 %build
95 %{__gettextize}
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         %{?with_static_libs:--enable-static}
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install -d $RPM_BUILD_ROOT/%{_lib}
111 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libgpg-error.so.* $RPM_BUILD_ROOT/%{_lib}
112 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libgpg-error.so.*.*.*) \
113         $RPM_BUILD_ROOT%{_libdir}/libgpg-error.so
114
115 %find_lang %{name}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README THANKS
126 %attr(755,root,root) %{_bindir}/gpg-error
127 %attr(755,root,root) /%{_lib}/libgpg-error.so.*.*.*
128 %attr(755,root,root) %ghost /%{_lib}/libgpg-error.so.0
129 %{_datadir}/libgpg-error
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/gpg-error-config
134 %attr(755,root,root) %{_bindir}/gpgrt-config
135 %attr(755,root,root) %{_bindir}/yat2m
136 %attr(755,root,root) %{_libdir}/libgpg-error.so
137 %{_libdir}/libgpg-error.la
138 %{_includedir}/gpg-error.h
139 %{_includedir}/gpgrt.h
140 %{_aclocaldir}/gpg-error.m4
141 %{_aclocaldir}/gpgrt.m4
142 %{_mandir}/man1/gpgrt-config.1*
143 %{_infodir}/gpgrt.info*
144 %{_pkgconfigdir}/gpg-error.pc
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgpg-error.a
150 %endif
151
152 %files -n common-lisp-gpg-error
153 %defattr(644,root,root,755)
154 %{_datadir}/common-lisp/source/gpg-error
This page took 0.189118 seconds and 3 git commands to generate.