]> git.pld-linux.org Git - SPECS.git/blob - libeio.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / libeio.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        libeio - an asynchronous I/O library
6 Name:           libeio
7 Version:        1.0
8 Release:        1
9 License:        BSD or GPL v2+
10 Group:          Libraries
11 Source0:        %{name}-20100311.tar.bz2
12 # Source0-md5:  a3b50842b683b3dfd17af57db767e484
13 # cvs -z3 -d :pserver:anonymous@cvs.schmorp.de/schmorpforge co libeio
14 URL:            http://software.schmorp.de/pkg/libeio
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 # inotify interface
18 BuildRequires:  glibc-devel >= 6:2.4
19 BuildRequires:  libtool
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Libeio is a full-featured asynchronous I/O library for C, modelled in
24 similar style and spirit as libev. Features include: asynchronous
25 read, write, open, close, stat, unlink, fdatasync, mknod, readdir etc.
26 (basically the full POSIX API). sendfile (native on solaris, linux,
27 hp-ux, freebsd, emulated everywehere else), readahead (emulated where
28 not available).
29
30 %package devel
31 Summary:        Header files for libeio library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libeio
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Header files for libeio library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki libeio.
41
42 %package static
43 Summary:        Static libeio library
44 Summary(pl.UTF-8):      Statyczna biblioteka libeio
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static libeio library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka libeio.
53
54 %prep
55 %setup -q -n %{name}
56
57 %build
58 %{__libtoolize}
59 %{__aclocal}
60 %{__autoconf}
61 %{__autoheader}
62 %{__automake}
63 %configure \
64         %{!?with_static_libs:--disable-static}
65
66 # override -O3 which overrides our optflags in configure
67 %{__make} \
68         CFLAGS="%{rpmcflags} -D_GNU_SOURCE"
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc Changes LICENSE
85 %attr(755,root,root) %{_libdir}/libeio.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libeio.so.1
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libeio.so
91 %{_libdir}/libeio.la
92 %{_includedir}/eio.h
93
94 %if %{with static_libs}
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libeio.a
98 %endif
This page took 0.332327 seconds and 3 git commands to generate.