]> git.pld-linux.org Git - SPECS.git/blob - libcuefile.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / libcuefile.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         rev     475
6 Summary:        Library for working with Cue Sheet (cue) and Table of Contents (toc) files
7 Summary(pl.UTF-8):      Biblioteka do pracy z plikami Cue Sheet (cue) oraz Table of Contents (toc)
8 Name:           libcuefile
9 Version:        0.0.1.r%{rev}
10 Release:        2
11 License:        GPL v2+
12 Group:          Libraries
13 #Source0Download: https://www.musepack.net/index.php?pg=src
14 Source0:        https://files.musepack.net/source/%{name}_r%{rev}.tar.gz
15 # Source0-md5:  1a6ac52e1080fd54f0f59372345f1e4e
16 URL:            https://www.musepack.net/
17 BuildRequires:  cmake >= 2.4
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Library for working with Cue Sheet (cue) and Table of Contents (toc)
22 files.
23
24 %description -l pl.UTF-8
25 Biblioteka do pracy z plikami list ścieżek cue (Cue Sheet) oraz toc
26 (Table of Contents).
27
28 %package devel
29 Summary:        Header files for CUE File library
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CUE File
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for CUE File library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki CUE File.
39
40 %package static
41 Summary:        Static version of the CUE File library
42 Summary(pl.UTF-8):      Statyczna wersja biblioteki CUE File
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static version of the CUE File library.
48
49 %description static -l pl.UTF-8
50 Statyczna wersja biblioteki CUE File.
51
52 %prep
53 %setup -q -n libcuefile_r%{rev}
54
55 %build
56 %cmake
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{_includedir}
65 %{__cp} -r include/cuetools $RPM_BUILD_ROOT%{_includedir}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS README
76 %attr(755,root,root) %{_libdir}/libcuefile.so.*.*.*
77 %attr(755,root,root) %ghost %{_libdir}/libcuefile.so.0
78
79 %files devel
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_libdir}/libcuefile.so
82 %{_includedir}/cuetools
83
84 %if %{with static_libs}
85 %files static
86 %defattr(644,root,root,755)
87 %{_libdir}/libcuefile.a
88 %endif
This page took 0.164058 seconds and 3 git commands to generate.