]> git.pld-linux.org Git - SPECS.git/blob - libbtctl.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / libbtctl.spec
1 #
2 # todo:
3 # - mono bindings (build crashes on ppc)
4 #
5 # Conditional build:
6 %bcond_with     apidocs         # enable gtk-doc
7 %bcond_without  static_libs     # don't build static library
8
9 Summary:        Bluetooth GObject based library
10 Summary(pl.UTF-8):      Biblioteka do programowania urządzeń Bluetooth
11 Name:           libbtctl
12 Version:        0.10.0
13 Release:        12
14 License:        GPL
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libbtctl/0.10/%{name}-%{version}.tar.bz2
17 # Source0-md5:  83d5f90efb2b26d1bd12a668940d02ba
18 Patch0:         %{name}-make-jN.patch
19 Patch1:         %{name}-newapi.patch
20 Patch2:         glib.patch
21 Patch3:         format-security.patch
22 URL:            http://usefulinc.com/software/gnome-bluetooth/
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  bluez-libs-devel >= 2.25
26 BuildRequires:  docbook-dtd412-xml
27 BuildRequires:  gettext-tools
28 BuildRequires:  glib2-devel >= 1:2.12.4
29 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
30 BuildRequires:  intltool >= 0.35.0
31 BuildRequires:  libtool
32 BuildRequires:  openobex-devel >= 1.2
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-devel >= 1:2.3
35 BuildRequires:  python-pygtk-devel >= 2.10.3
36 BuildRequires:  rpm-pythonprov
37 Requires:       bluez-libs >= 2.25
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This package contains a library to control Bluetooth devices.
42
43 %description -l pl.UTF-8
44 Ten pakiet zawiera bibliotekę do kontrolowania urządzeń Bluetooth.
45
46 %package devel
47 Summary:        Header files for libbtctl library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libbtctl
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       bluez-libs-devel >= 2.25
52 Requires:       glib2-devel >= 1:2.12.4
53 Requires:       openobex-devel >= 1.2
54
55 %description devel
56 Header files for libbtctl library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki libbtctl.
60
61 %package static
62 Summary:        Static libbtctl library
63 Summary(pl.UTF-8):      Statyczna biblioteka libbtctl
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static libbtctl library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka libbtctl.
72
73 %package -n python-btctl
74 Summary:        Python bindings for libbtctl library
75 Summary(pl.UTF-8):      Wiązania dla języka Python biblioteki libbtctl
76 Group:          Libraries/Python
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       python-libs
79
80 %description -n python-btctl
81 Static libbtctl library.
82
83 %description -n python-btctl -l pl.UTF-8
84 Wiązania dla języka Python biblioteki libbtctl.
85
86 %package apidocs
87 Summary:        libbtctl API documentation
88 Summary(pl.UTF-8):      Dokumentacja API libbtctl
89 Group:          Documentation
90 Requires:       gtk-doc-common
91 BuildArch:      noarch
92
93 %description apidocs
94 libbtctl API documentation.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API libbtctl.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoheader}
110 %{__autoconf}
111 %{__automake}
112 %configure \
113         --disable-mono \
114         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
115         --with-html-path=%{_gtkdocdir} \
116         %{!?with_static_libs:--disable-static}
117 %{__make} \
118         pydir=%{py_sitedir}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         HTML_DIR=%{_gtkdocdir} \
126         pydir=%{py_sitedir}
127
128 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
129
130 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
131
132 %find_lang %{name}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog README
143 %attr(755,root,root) %{_libdir}/libbtctl.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libbtctl.so.4
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libbtctl.so
149 %{_libdir}/libbtctl.la
150 %{_includedir}/%{name}
151 %{_pkgconfigdir}/libbtctl.pc
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libbtctl.a
157 %endif
158
159 %files -n python-btctl
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{py_sitedir}/btctl.so
162
163 %if %{with apidocs}
164 %files apidocs
165 %defattr(644,root,root,755)
166 %{_gtkdocdir}/libbtctl
167 %endif
This page took 0.201033 seconds and 3 git commands to generate.