]> git.pld-linux.org Git - SPECS.git/blob - libasyncns.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / libasyncns.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        C library for executing name service queries asynchronously
6 Summary(pl.UTF-8):      Biblioteka C do asynchronicznego wykonywania zapytań o nazwy
7 Name:           libasyncns
8 Version:        0.8
9 Release:        2
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://0pointer.de/lennart/projects/libasyncns/%{name}-%{version}.tar.gz
13 # Source0-md5:  1f553d6ce1ad255bc83b3d8e9384f515
14 Patch0:         %{name}-link.patch
15 URL:            http://0pointer.de/lennart/projects/libasyncns/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  libtool
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 libasyncns is a C library for Linux/Unix for executing name service
23 queries asynchronously. It is an asynchronous wrapper around
24 getaddrinfo(3) and getnameinfo(3) from the libc.
25
26 In contrast to GNU's asynchronous name resolving API getaddrinfo_a(),
27 libasyncns does not make use of UNIX signals for reporting completion
28 of name queries. Instead, the API exports a standard UNIX file
29 descriptor which may be integerated cleanly into custom main loops.
30
31 %description -l pl.UTF-8
32 libasyncns to biblioteka C dla Linuksa/Uniksa do asynchronicznego
33 wykonywania zapytań o nazwy. Jest to asynchroniczne obudowanie dla
34 funkcji getaddrinfo(3) i getnameinfo(3) z libc.
35
36 W przeciwieństwie do asynchronicznego API rozwiązywania nazw GNU,
37 getaddrinfo_a(), libasyncns nie wykorzystuje uniksowych sygnałów do
38 informowania o zakończeniu zapytań. Zamiast tego API eksportuje
39 standardowy uniksowy deskryptor pliku, który można łatwo zintegrować
40 we własnych głównych pętlach.
41
42 %package devel
43 Summary:        Header files for libasyncns library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libasyncns
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for libasyncns library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki libasyncns.
53
54 %package static
55 Summary:        Static libasyncns library
56 Summary(pl.UTF-8):      Statyczna biblioteka libasyncns
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static libasyncns library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka libasyncns.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 %build
71 %{__libtoolize}
72 %{__aclocal} -I m4
73 %{__autoconf}
74 %{__autoheader}
75 %{__automake}
76 # no need to generate doc/README from doc/README.html, there is README anyway
77 %configure \
78         --disable-lynx \
79         %{!?with_static_libs:--disable-static}
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc README
97 %attr(755,root,root) %{_libdir}/libasyncns.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libasyncns.so.0
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libasyncns.so
103 %{_libdir}/libasyncns.la
104 %{_includedir}/asyncns.h
105 %{_pkgconfigdir}/libasyncns.pc
106
107 %if %{with static_libs}
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libasyncns.a
111 %endif
This page took 0.460029 seconds and 3 git commands to generate.