]> git.pld-linux.org Git - SPECS.git/blob - libArcus.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / libArcus.spec
1 Summary:        Communication library between internal components for Ultimaker software
2 Summary(pl.UTF-8):      Biblioteka komunikacji między wewnętrznymi komponentami oprogramowania Ultimaker
3 Name:           libArcus
4 Version:        4.5.0
5 Release:        5
6 License:        AGPL v3+
7 Group:          Libraries
8 #Source0Download: https://github.com/Ultimaker/libArcus/releases
9 Source0:        https://github.com/Ultimaker/libArcus/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  2966fc6e19f0ace9803cc90754a5f0fd
11 Patch0:         PyQt5-sip.patch
12 URL:            https://github.com/Ultimaker/libArcus
13 BuildRequires:  cmake >= 2.8.12
14 BuildRequires:  libstdc++-devel >= 6:4.7
15 BuildRequires:  protobuf-devel >= 3.0.0
16 BuildRequires:  python3-devel >= 1:3.2
17 BuildRequires:  python3-sip-devel
18 BuildRequires:  sip
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Arcus library contains C++ code and Python 3 bindings for creating a
23 socket in a thread and using this socket to send and receive messages
24 based on the Protocol Buffers library. It is designed to facilitate
25 the communication between Cura and its backend and similar code.
26
27 %description -l pl.UTF-8
28 Biblioteka Arcus zawiera kod C++ oraz wiązania Pythona 3 do tworzenia
29 gniazda w wątku i wykorzystywania tego gniazda do wysyłania i
30 odbierania komunikatów w oparciu o bibliotekę Protocol Buffers.
31 Została zaprojektowana, aby ułatwić komunikację między programem Cura
32 a jego backendem i podobnym kodem.
33
34 %package devel
35 Summary:        Development files for libArcus
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libArcus
37 License:        AGPL v3+ and BSD
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Development files for libArcus.
43
44 %description devel -l pl
45 Pliki programistyczne biblioteki libArcus.
46
47 %package -n python3-Arcus
48 Summary:        Python 3 bindings for libArcus
49 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki libArcus
50 Group:          Libraries/Python
51 Requires:       %{name} = %{version}-%{release}
52
53 %description -n python3-Arcus
54 Arcus Python 3 bindings for creating a socket in a thread and using
55 this socket to send and receive messages based on the Protocol Buffers
56 library. It is designed to facilitate the communication between Cura
57 and its backend and similar code.
58
59 %description -n python3-Arcus -l pl.UTF-8
60 Wiązania Pythona 3 do biblioteki Arcus, tworzącej gniazdo w wątku i
61 wykorzystującej to gniazdo do wysyłania i odbierania komunikatów w
62 oparciu o bibliotekę Protocol Buffers. Biblioteka została
63 zaprojektowana, aby ułatwić komunikację między programem Cura a jego
64 backendem i podobnym kodem.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 %build
71 mkdir build
72 cd build
73 %cmake .. \
74         -DBUILD_EXAMPLES:BOOL=OFF \
75         -DCMAKE_SKIP_RPATH:BOOL=ON
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{py3_sitedir}
82
83 %{__make} -C build install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 # python location detection is totally screwed in this package
87 %{__mv} $RPM_BUILD_ROOT{/usr/local/%{_lib}/python3*/site-packages,%{py3_sitedir}}/Arcus.so
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README.md TODO.md
98 %attr(755,root,root) %{_libdir}/libArcus.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libArcus.so.3
100
101 %files devel
102 %defattr(644,root,root,755)
103 %doc examples/example.cpp examples/example.proto
104 %attr(755,root,root) %{_libdir}/libArcus.so
105 %{_includedir}/Arcus
106 %{_libdir}/cmake/Arcus
107
108 %files -n python3-Arcus
109 %defattr(644,root,root,755)
110 %doc examples/example.py
111 %attr(755,root,root) %{py3_sitedir}/Arcus.so
This page took 0.142696 seconds and 3 git commands to generate.