]> git.pld-linux.org Git - SPECS.git/blob - koules.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / koules.spec
1 #
2 # Conditional build:
3 %bcond_without  svga    # without SVGAlib version
4 #
5 Summary:        SVGAlib/X11 action game with multiplayer, network and sound support
6 Summary(pl.UTF-8):      Gra pod SVGAlib i X11 dla wielu graczy
7 Name:           koules
8 Version:        1.4
9 Release:        4
10 License:        GPL
11 Group:          Applications/Games
12 #Source0:       ftp://sunsite.unc.edu/pub/Linux/games/arcade/%{name}/%{name}%{version}-src.tar.gz
13 Source0:        ftp://ftp.icm.edu.pl/mirrors/sunsite.unc.edu/pub/Linux/games/arcade/%{name}/%{name}%{version}-src.tar.gz
14 # Source0-md5:  0a5ac9e57c8b72e9fc200bc98273235c
15 Source1:        %{name}.svga.6.pl
16 Patch0:         %{name}-config.patch
17 Patch1:         %{name}-asmfix.patch
18 Patch2:         %{name}-optflags.patch
19 Patch3:         %{name}-noman.patch
20 Patch4:         %{name}-gcc3.patch
21 Patch5:         %{name}-home_etc.patch
22 Patch6:         %{name}-asm_io.patch
23 BuildRequires:  perl-base
24 %{?with_svga:BuildRequires:     svgalib-devel}
25 BuildRequires:  xorg-cf-files
26 BuildRequires:  xorg-lib-libXext-devel
27 BuildRequires:  xorg-util-gccmakedep
28 BuildRequires:  xorg-util-imake
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 SVGAlib/X11 action game with multiplayer, network and sound support.
33
34 %description -l pl.UTF-8
35 Gra pod SVGAlib i X11 ze wsparciem dla wielu graczy, sieci i dźwięku.
36
37 %package svga
38 Summary:        SVGAlib action game with multiplayer, network and sound support
39 Summary(pl.UTF-8):      Gra pod SVGAlib dla wielu graczy
40 Group:          Applications/Games
41
42 %description svga
43 SVGAlib action game with multiplayer, network and sound support.
44
45 %description svga -l pl.UTF-8
46 Gra pod SVGAlib ze wsparciem dla wielu graczy, sieci i dźwięku.
47
48 %package x11
49 Summary:        X action game with multiplayer, network and sound support
50 Summary(pl.UTF-8):      Gra pod X dla wielu graczy
51 Group:          X11/Applications/Games
52
53 %description x11
54 X action game with multiplayer, network and sound support
55
56 %description x11 -l pl.UTF-8
57 Gra pod X ze wsparciem dla wielu graczy, sieci i dźwięku.
58
59 %package sound
60 Summary:        Sound files for koules/xkoules
61 Summary(pl.UTF-8):      Pliki dźwiękowe dla koules/xkoules
62 Group:          Applications/Games
63
64 %description sound
65 Sound files for koules/xkoules.
66
67 %description sound -l pl.UTF-8
68 Pliki dźwiękowe dla koules/xkoules.
69
70 %prep
71 %setup -q -n %{name}%{version}
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77 %patch5 -p1
78 %patch6 -p1
79
80 %ifarch %{ix86}
81 %{__perl} -pi -e 's/^.*I386ASSEMBLY.*$/#define I386ASSEMBLY/' Iconfig
82 %endif
83 %{__perl} -pi -e 's@/usr/lib/koules@%{_libdir}/koules@' koules.tcl
84
85 %build
86 %if %{with svga}
87 %{__make} -f Makefile.svgalib \
88         OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
89         KLIBDIR="%{_libdir}"
90 %endif
91
92 xmkmf -a
93 %{__make} -f Makefile clean
94 %{__make} -j1 \
95         CDEBUGFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
96         KLIBDIR="%{_libdir}"
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_mandir}{,/pl}/man6,%{_bindir},%{_libdir}/koules}
101
102 %if %{with svga}
103 install koules.svga $RPM_BUILD_ROOT%{_bindir}
104 install koules.svga.6 $RPM_BUILD_ROOT%{_mandir}/man6
105 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man6/koules.svga.6
106 %endif
107
108 install sounds/*.raw $RPM_BUILD_ROOT%{_libdir}/koules
109 install koules.sndsrv.linux $RPM_BUILD_ROOT%{_libdir}/koules
110 install xkoules $RPM_BUILD_ROOT%{_bindir}/xkoules
111 install xkoules.6 $RPM_BUILD_ROOT%{_mandir}/man6/xkoules.6
112 install koules $RPM_BUILD_ROOT%{_bindir}/koules
113 install koules.tcl $RPM_BUILD_ROOT%{_bindir}/koules.tcl
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %if %{with svga}
119 %files svga
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/koules.svga
122 %attr(755,root,root) %{_bindir}/koules
123 %{_mandir}/man6/koules.svga.6*
124 %lang(pl) %{_mandir}/pl/man6/koules.svga.6*
125 %endif
126
127 %files x11
128 %defattr(644,root,root,755)
129 %doc ANNOUNCE BUGS Card ChangeLog Koules.FAQ README TODO *.xpm
130 %attr(755,root,root) %{_bindir}/xkoules
131 %attr(755,root,root) %{_bindir}/koules.tcl
132 %{_mandir}/man6/xkoules.6*
133
134 %files sound
135 %defattr(644,root,root,755)
136 %dir %{_libdir}/koules
137 %attr(755,root,root) %{_libdir}/koules/koules.sndsrv.linux
138 %{_libdir}/koules/*.raw
This page took 0.46558 seconds and 3 git commands to generate.