]> git.pld-linux.org Git - SPECS.git/blob - kde4-krdc.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / kde4-krdc.spec
1 #
2 # Conditional build:
3 #
4 %define         _state          stable
5 %define         orgname         krdc
6 %define         qtver           4.8.3
7
8 Summary:        Virtual Desktops
9 Summary(pl.UTF-8):      Wirtualne biurka
10 Name:           kde4-krdc
11 Version:        4.14.3
12 Release:        4
13 License:        GPL v2+
14 Group:          X11/Applications
15 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
16 # Source0-md5:  7e796905eb8579e457c6ead2f1c21525
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt3Support-devel >= %{qtver}
19 BuildRequires:  QtOpenGL-devel >= %{qtver}
20 BuildRequires:  QtScript-devel >= %{qtver}
21 BuildRequires:  QtSql-devel >= %{qtver}
22 BuildRequires:  QtSvg-devel >= %{qtver}
23 BuildRequires:  QtTest-devel >= %{qtver}
24 BuildRequires:  QtWebKit-devel >= %{qtver}
25 BuildRequires:  alsa-lib-devel
26 BuildRequires:  automoc4 >= 0.9.88
27 BuildRequires:  boost-devel
28 BuildRequires:  cmake >= 2.8.0
29 BuildRequires:  giflib-devel
30 BuildRequires:  gmp-devel
31 BuildRequires:  gpgme-devel
32 BuildRequires:  jasper-devel
33 BuildRequires:  kde4-kdebase-devel >= %{version}
34 BuildRequires:  kde4-kdebase-workspace-devel >= 4.11.4
35 BuildRequires:  kde4-kdelibs-devel >= %{version}
36 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
37 BuildRequires:  libgadu-devel >= 1.8.0
38 BuildRequires:  libidn-devel
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libktorrent-devel >= 1.0.2
41 BuildRequires:  libmms-devel
42 BuildRequires:  libmsn-devel >= 4.1
43 BuildRequires:  libotr-devel >= 4.0.0
44 BuildRequires:  libv4l-devel >= 0.5.8
45 BuildRequires:  libvncserver-devel
46 BuildRequires:  libxml2-progs
47 BuildRequires:  libxslt-devel >= 1.0.7
48 BuildRequires:  meanwhile-devel >= 1.0.1
49 BuildRequires:  mediastreamer-devel >= 2.3.0
50 BuildRequires:  openssl-devel >= 0.9.7d
51 BuildRequires:  ortp-devel >= 0.16.1-3
52 BuildRequires:  pcre-devel
53 BuildRequires:  pkgconfig
54 BuildRequires:  qca-devel >= 2.0
55 BuildRequires:  qimageblitz-devel >= 0.0.6
56 BuildRequires:  qt4-build >= %{qtver}
57 BuildRequires:  qt4-qmake >= %{qtver}
58 BuildRequires:  rpm-pythonprov
59 BuildRequires:  rpmbuild(macros) >= 1.600
60 BuildRequires:  shared-desktop-ontologies-devel >= 0.5
61 BuildRequires:  soprano-devel >= 2.4.64
62 BuildRequires:  speex-devel
63 BuildRequires:  sqlite3-devel
64 BuildRequires:  strigi-devel >= 0.7.2
65 BuildRequires:  telepathy-qt4-devel >= 0.9.0
66 BuildRequires:  xmms-devel
67 BuildRequires:  xorg-lib-libXdamage-devel
68 BuildRequires:  xorg-lib-libXtst-devel
69 Requires:       kde4-kdebase >= %{version}
70 # needed for /usr/share/telepathy
71 Requires:       telepathy-mission-control
72 Suggests:       rdesktop
73 Suggests:       xfreerdp
74 Obsoletes:      kde4-kdenetwork-kopete-tool-alias
75 Obsoletes:      kdenetwork4
76 Conflicts:      kdenetwork4
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 Remote Desktop Connection is a client application that allows you to
81 view or even control the desktop session on another machine that is
82 running a compatible (VNC) server. You would typically use Remote
83 Desktop Connection with the KDE VNC server, which is Desktop Sharing
84 (also provided in this package), since it closely matches the special
85 features of Remote Desktop Connection.
86
87 %description -l pl.UTF-8
88 Remote Desktop Connection to aplikacja kliencka umożliwiająca
89 oglądanie a nawet sterowanie sesją na innej maszynie z działającym
90 kompatybilnym serwerem (VNC). Zwykle używa się Remote Desktop
91 Connection z użyciem serwera KDE VNC, czyli "dzielenia pulpitu" (także
92 dostarczanego przez ten pakiet), jako że najlepiej pasuje do
93 specjalnych możliwości Remote Desktop Connection.
94
95 %prep
96 %setup -q -n %{orgname}-%{version}
97
98 %build
99 install -d build
100 cd build
101 %cmake \
102         -DMOZPLUGIN_INSTALL_DIR=%{_browserpluginsdir} \
103         ../
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} -C build install \
111         DESTDIR=$RPM_BUILD_ROOT \
112         kde_htmldir=%{_kdedocdir}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/krdc
123 %attr(755,root,root) %{_bindir}/krdc_rfb_approver
124 %attr(755,root,root) %ghost %{_libdir}/libkrdccore.so.?
125 %attr(755,root,root) %{_libdir}/libkrdccore.so.*.*.*
126 %attr(755,root,root) %{_libdir}/kde4/krdc_rdpplugin.so
127 %attr(755,root,root) %{_libdir}/kde4/krdc_testplugin.so
128 %attr(755,root,root) %{_libdir}/kde4/krdc_vncplugin.so
129 %attr(755,root,root) %{_libdir}/kde4/kcm_krdc_rdpplugin.so
130 %attr(755,root,root) %{_libdir}/kde4/kcm_krdc_vncplugin.so
131 %{_datadir}/apps/krdc
132 %{_datadir}/apps/krdc_rfb_approver
133 %{_datadir}/config.kcfg/krdc.kcfg
134 %{_datadir}/kde4/services/ServiceMenus/smb2rdc.desktop
135 %{_datadir}/kde4/services/rdp.protocol
136 %{_datadir}/kde4/services/vnc.protocol
137 %{_datadir}/kde4/services/krdc_rdp.desktop
138 %{_datadir}/kde4/services/krdc_rdp_config.desktop
139 %{_datadir}/kde4/services/krdc_test.desktop
140 %{_datadir}/kde4/services/krdc_vnc.desktop
141 %{_datadir}/kde4/services/krdc_vnc_config.desktop
142 %{_datadir}/kde4/servicetypes/krdc_plugin.desktop
143 %{_desktopdir}/kde4/krdc.desktop
144 %{_kdedocdir}/en/krdc
145 %{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.kr*.service
146 %{_datadir}/telepathy/clients/kr*.client
147
This page took 0.177773 seconds and 3 git commands to generate.