]> git.pld-linux.org Git - SPECS.git/blob - kde4-kppp.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / kde4-kppp.spec
1 # TODO
2 # - fix kopete-tool-{avdeviceconfig,smpppdcs} summaries/descriptions (copy-pastos!)
3 # - BR phonon-devel
4 # - FILES update
5 #
6 # Conditional build:
7 #
8 %define         _state          stable
9 %define         orgname         kppp
10 %define         qtver           4.8.3
11
12 Summary:        KDE PPP dialer
13 Summary(pl.UTF-8):      Program do połączeń modemowych dla KDE
14 Summary(pt_BR.UTF-8):   O discador para Internet
15 Name:           kde4-%{orgname}
16 Version:        4.12.0
17 Release:        1
18 License:        GPL v2+
19 Group:          X11/Applications
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
21 # Source0-md5:  2899d881b8fff48ba3122204f15bf1dc
22 URL:            http://www.kde.org/
23 BuildRequires:  Qt3Support-devel >= %{qtver}
24 BuildRequires:  QtOpenGL-devel >= %{qtver}
25 BuildRequires:  QtScript-devel >= %{qtver}
26 BuildRequires:  QtSql-devel >= %{qtver}
27 BuildRequires:  QtSvg-devel >= %{qtver}
28 BuildRequires:  QtTest-devel >= %{qtver}
29 BuildRequires:  QtWebKit-devel >= %{qtver}
30 BuildRequires:  alsa-lib-devel
31 BuildRequires:  automoc4 >= 0.9.88
32 BuildRequires:  boost-devel
33 BuildRequires:  cmake >= 2.8.0
34 BuildRequires:  giflib-devel
35 BuildRequires:  gmp-devel
36 BuildRequires:  gpgme-devel
37 BuildRequires:  jasper-devel
38 BuildRequires:  kde4-kdebase-devel >= %{version}
39 BuildRequires:  kde4-kdebase-workspace-devel >= 4.11.4
40 BuildRequires:  kde4-kdelibs-devel >= %{version}
41 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
42 BuildRequires:  libgadu-devel >= 1.8.0
43 BuildRequires:  libidn-devel
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libktorrent-devel >= 1.0.2
46 BuildRequires:  libmms-devel
47 BuildRequires:  libmsn-devel >= 4.1
48 BuildRequires:  libotr-devel >= 4.0.0
49 BuildRequires:  libv4l-devel >= 0.5.8
50 BuildRequires:  libvncserver-devel
51 BuildRequires:  libxml2-progs
52 BuildRequires:  libxslt-devel >= 1.0.7
53 BuildRequires:  meanwhile-devel >= 1.0.1
54 BuildRequires:  mediastreamer-devel >= 2.3.0
55 BuildRequires:  msilbc-devel >= 2.0.1
56 BuildRequires:  openssl-devel >= 0.9.7d
57 BuildRequires:  ortp-devel >= 0.16.1-3
58 BuildRequires:  pcre-devel
59 BuildRequires:  pkgconfig
60 BuildRequires:  qca-devel >= 2.0
61 BuildRequires:  qimageblitz-devel >= 0.0.6
62 BuildRequires:  qt4-build >= %{qtver}
63 BuildRequires:  qt4-qmake >= %{qtver}
64 BuildRequires:  rpm-pythonprov
65 BuildRequires:  rpmbuild(macros) >= 1.600
66 BuildRequires:  shared-desktop-ontologies-devel >= 0.5
67 BuildRequires:  soprano-devel >= 2.4.64
68 BuildRequires:  speex-devel
69 BuildRequires:  sqlite3-devel
70 BuildRequires:  strigi-devel >= 0.7.2
71 BuildRequires:  telepathy-qt4-devel >= 0.9.0
72 BuildRequires:  xmms-devel
73 BuildRequires:  xorg-lib-libXdamage-devel
74 BuildRequires:  xorg-lib-libXtst-devel
75 Obsoletes:      kde4-kdenetwork-kppp
76 Conflicts:      kde4-kdenetwork
77 Requires:       kde4-kdebase >= %{version}
78 Requires:       ppp
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 KPPP is a dialer and front end for pppd. It allows for interactive
83 script generation and network setup. It will automate the dialing in
84 process to your ISP while letting you conveniently monitor the entire
85 process.
86
87 Once connected KPPP will provide a rich set of statistics and keep
88 track of the time spent online for you.
89
90 A built-in terminal and script generator will enable you to set up
91 your connection with ease. You will no longer need an additional
92 terminal program such as seyon or minicom to test and setup your
93 connection.
94
95 KPPP features elaborate phone cost accounting, which enables you to
96 easily track your online costs.
97
98 %description -l pl.UTF-8
99 KPPP to program do nawiązywania połączeń modemowych i frontend dla
100 pppd. Pozwala na interaktywne generowanie skryptów i konfiguracji
101 sieci. Automatyzuje proces dzwonienia do swojego ISP umożliwiając
102 jednocześnie wygodne monitorowanie całego procesu.
103
104 Po połączeniu KPPP udostępnia bogate statystyki i śledzi czas spędzony
105 online.
106
107 Wbudowany terminal i generator skryptów umożliwia łatwe
108 skonfigurowanie połączenia. Nie trzeba już dodatkowego programu
109 terminalowego, takiego jak seyon czy minicom, do testowania i
110 ustawiania połączenia.
111
112 KPPP ma wypracowane naliczanie kosztów telefonów, pozwalające łatwo
113 śledzić koszt czasu online.
114
115 %description -l pt_BR.UTF-8
116 O discador para Internet.
117
118 %prep
119 %setup -q -n %{orgname}-%{version}
120
121 %build
122 install -d build
123 cd build
124 %cmake \
125         -DMOZPLUGIN_INSTALL_DIR=%{_browserpluginsdir} \
126         ../
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} -C build install \
134         DESTDIR=$RPM_BUILD_ROOT \
135         kde_htmldir=%{_kdedocdir}
136
137 %find_lang      %{orgname}      --with-kde
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files -f %{orgname}.lang
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/kppplogview
145 %attr(755,root,root) %{_bindir}/kppp
146 %{_datadir}/apps/kppp
147 %{_datadir}/dbus-1/interfaces/org.kde.kppp.xml
148 %{_desktopdir}/kde4/Kppp.desktop
149 %{_desktopdir}/kde4/kppplogview.desktop
150 %{_iconsdir}/*/*/*/kppp.png
This page took 0.046041 seconds and 3 git commands to generate.