]> git.pld-linux.org Git - SPECS.git/blob - kde4-baloo-widgets.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / kde4-baloo-widgets.spec
1 # $Revision:$, $Date:$
2 %define         _state          stable
3 %define         orgname         baloo-widgets
4 %define         qtver           4.8.3
5
6 Summary:        A framework for searching and managing metadata - widgets
7 Name:           kde4-baloo-widgets
8 Version:        4.14.3
9 Release:        3
10 License:        LGPLv2 or LGPLv3
11 Group:          X11/Applications
12 URL:            http://www.kde.org/
13 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
14 # Source0-md5:  9ee2a741c502b924a9575a96f10bb5f8
15 BuildRequires:  QtCore-devel >= %{qtver}
16 BuildRequires:  akonadi-devel >= 1.12.0
17 BuildRequires:  kde4-baloo-devel >= %{version}
18 BuildRequires:  kde4-kdelibs-devel >= %{version}
19 BuildRequires:  kde4-kfilemetadata-devel >= %{version}
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 A framework for searching and managing metadata - widgets.
25
26 %package devel
27 Summary:        Developer files for %{name}
28 Group:          X11/Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30 Requires:       kde4-baloo-devel >= %{version}
31
32 %description devel
33 Baloo widgets development files and libraries.
34
35 %prep
36 %setup -q -n %{orgname}-%{version}
37
38 %build
39 install -d build
40 cd build
41 %cmake \
42                 -DHTML_INSTALL_DIR=%{_kdedocdir} \
43                 -DKDE_DISTRIBUTION_TEXT="PLD-Linux" \
44                 -DKDE4_ENABLE_FINAL=OFF \
45                 ../
46
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} -C build install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_libdir}/libbaloowidgets.so.*.*.*
64 %attr(755,root,root) %ghost %{_libdir}/libbaloowidgets.so.?
65
66 %files devel
67 %defattr(644,root,root,755)
68 %{_includedir}/baloo/*.h
69 %attr(755,root,root) %{_libdir}/libbaloowidgets.so
70 %{_libdir}/cmake/BalooWidgets
This page took 0.033356 seconds and 3 git commands to generate.