]> git.pld-linux.org Git - SPECS.git/blob - jsext.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / jsext.spec
1 Summary:        JavaScript implementation
2 Summary(pl.UTF-8):      Implementacja JavaScriptu
3 Name:           jsext
4 Version:        0.12
5 Release:        1
6 License:        LGPL or GPL or Mozilla Public License 1.1, part BSD
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/jsext/%{name}-%{version}.tar.gz
9 # Source0-md5:  9980d5bdcec8d4a2b5455f3264b42184
10 URL:            http://www.jsext.net/
11 BuildRequires:  readline-devel
12 BuildRequires:  rpmbuild(macros) >= 1.294
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 JavaScript Reference Implementation (codename SpiderMonkey). The
17 package contains JavaScript runtime (compiler, interpreter,
18 decompiler, garbage collector, atom manager, standard classes) and
19 small "shell" program that can be used interactively and with .js
20 files to run scripts. This version extends the interpreter with the
21 ability to access libraries written in C.
22
23 %description -l pl.UTF-8
24 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
25 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
26 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
27 która może być używana interaktywnie lub z plikami .js do uruchamiania
28 skryptów. Ta wersja rozszerza interpreter o możliwość dostępu do
29 bibliotek napisanych w C.
30
31 %package devel
32 Summary:        Header files for JavaScript library
33 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for JavaScript library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe do biblioteki JavaScript.
42
43 %package static
44 Summary:        Static JavaScript library
45 Summary(pl.UTF-8):      Statyczna biblioteka JavaScript
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static version of JavaScript library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka JavaScript.
54
55 %prep
56 %setup -q
57
58 %build
59 %configure
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/js}
65
66 %{__make} install \
67         libdir=$RPM_BUILD_ROOT%{_libdir} \
68         bindir=$RPM_BUILD_ROOT%{_bindir}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_bindir}/jsext*
79 %attr(755,root,root) %{_libdir}/libjsext.so.*.*
80 %dir %{_libdir}/%{name}-%{version}
81 %attr(755,root,root) %{_libdir}/%{name}-%{version}/*.so
82
83 #%files devel
84 #%defattr(644,root,root,755)
85 #%attr(755,root,root) %{_libdir}/libjs.so
86 #%dir %{_includedir}/js
87 #%{_includedir}/js/js.msg
88 #%{_includedir}/js/jsopcode.tbl
89 #%{_includedir}/js/js[!j]*.h
90
91 #%files static
92 #%defattr(644,root,root,755)
93 #%{_libdir}/libjs.a
This page took 0.175578 seconds and 3 git commands to generate.