]> git.pld-linux.org Git - SPECS.git/blob - jquery-zclip.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / jquery-zclip.spec
1 # NOTES
2 # - bundles ZeroClipboard 1.0.7, adds jQuery wrapper
3 # TODO
4 # - patch default .swf path?
5 %define         plugin  zclip
6 Summary:        jQuery ZeroClipboard
7 Name:           jquery-%{plugin}
8 Version:        1.1.1
9 Release:        1
10 License:        MIT
11 Group:          Applications/WWW
12 Source0:        http://www.steamdev.com/zclip/archive/jquery.%{plugin}.%{version}.zip
13 # Source0-md5:  e80f36a66e2c0fbc10454fc78acfea52
14 URL:            http://www.steamdev.com/zclip/
15 BuildRequires:  rpmbuild(macros) >= 1.553
16 BuildRequires:  unzip
17 Requires:       jquery
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _appdir %{_datadir}/jquery/%{plugin}
22
23 %description
24 zClip is a lightweight jQuery "copy to clipboard" plugin built using
25 the popular Zero Clipboard library. This plugin uses an invisible
26 Adobe Flash movie that is fully compatible with Flash Player 10 and
27 below.
28
29 Features:
30 - Compatible with Flash 10
31 - Avoids built in browser security conflicts by using a 3rd party
32   browser plugin (Adobe Flash)
33 - Invisible overlay, no interference with page design
34 - Support for CSS ":hover" and ":active" states
35 - Preserves the targeted element's "click" "mouseenter" and
36   "mouseleave" events
37 - Supplies callback functions for "before copy" and "after copy"
38 - Extremely light weight! (~7KB minified)
39
40 %prep
41 %setup -qc
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_appdir}
46
47 cp -p jquery.%{plugin}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
48 cp -p jquery.%{plugin}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.js
49 ln -s %{plugin}-%{version}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.src.js
50 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
51
52 cp -p *.swf $RPM_BUILD_ROOT%{_appdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{_appdir}
This page took 0.088514 seconds and 3 git commands to generate.