]> git.pld-linux.org Git - SPECS.git/blob - jquery-sortable.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / jquery-sortable.spec
1 %define         plugin  sortable
2 Summary:        A flexible, opinionated sorting plugin for jQuery
3 Name:           jquery-%{plugin}
4 Version:        0.9.11
5 Release:        1
6 License:        Modified BSD License
7 Group:          Applications/WWW
8 Source0:        https://github.com/johnny/jquery-sortable/archive/%{version}/%{plugin}-%{version}.tar.gz
9 # Source0-md5:  66eff7676421f96dd05c58451ca4ec61
10 Source1:        http://johnny.github.io/jquery-sortable/js/jquery-sortable.js
11 # Source1-md5:  d51d97a074b2d39fdc27b85c2c1a7f3f
12 Source2:        http://johnny.github.io/jquery-sortable/js/jquery-sortable-min.js
13 # Source2-md5:  1f36199dcb98956681fefc63fa3babef
14 URL:            http://johnny.github.io/jquery-sortable/
15 Requires:       jquery >= 1.7.0
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _appdir %{_datadir}/jquery/%{plugin}
20
21 %description
22 jQuery Sortable is a flexible, opinionated sorting plugin. It enables
23 items in a list (or table etc.) to be sorted horizontally and
24 vertically using the mouse. Supports nested lists and pure drag/drop
25 containers.
26
27 jQuery Sortable does not depend on jQuery UI and works well with
28 Twitter's Bootstrap (You can even sort the Bootstrap navigation).
29
30 %package demo
31 Summary:        Demo for jQuery.%{plugin}
32 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu jQuery.%{plugin}
33 Group:          Development
34 Requires:       %{name} = %{version}-%{release}
35
36 %description demo
37 Demonstrations and samples for jQuery.%{plugin}.
38
39 %prep
40 %setup -q
41 cp -p %{SOURCE1} .
42 cp -p %{SOURCE2} .
43
44 %build
45 grep 'jquery-sortable.js v%{version}' jquery-%{plugin}.js
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
50
51 cp -p jquery-%{plugin}-min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
52 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
53 cp -p jquery-%{plugin}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.src.js
54 ln -s %{plugin}-%{version}.src.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.src.js
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README.mkd LICENSE CHANGELOG TODO
62 %{_appdir}
This page took 0.696357 seconds and 3 git commands to generate.