]> git.pld-linux.org Git - SPECS.git/blob - jquery-lazyload.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / jquery-lazyload.spec
1 %define         plugin  lazyload
2 Summary:        jQuery plugin for lazy loading images
3 Name:           jquery-%{plugin}
4 Version:        1.9.1
5 Release:        1
6 License:        MIT
7 Group:          Applications/WWW
8 Source0:        https://github.com/tuupola/jquery_lazyload/archive/%{version}/%{plugin}-%{version}.tar.gz
9 # Source0-md5:  7ecf440856495018d0d26c8a7660ac65
10 URL:            http://www.appelsiini.net/projects/lazyload
11 Requires:       jquery
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _appdir %{_datadir}/jquery/%{plugin}
16
17 %description
18 Lazy Load delays loading of images in long web pages. Images outside
19 of viewport wont be loaded before user scrolls to them. This is
20 opposite of image preloading.
21
22 Using Lazy Load on long web pages containing many large images makes
23 the page load faster. Browser will be in ready state after loading
24 visible images. In some cases it can also help to reduce server load.
25
26 Lazy Load is inspired by YUI ImageLoader Utility by Matt Mlinac.
27
28 %prep
29 %setup -qn jquery_%{plugin}-%{version}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
34
35 cp -p jquery.%{plugin}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
36 cp -p jquery.%{plugin}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.js
37 ln -s %{plugin}-%{version}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.src.js
38 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
39 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.min.js
40
41 # package also scrollstop in this package
42 cp -p jquery.scrollstop.min.js $RPM_BUILD_ROOT%{_appdir}/scrollstop-%{version}.min.js
43 cp -p jquery.scrollstop.js $RPM_BUILD_ROOT%{_appdir}/scrollstop-%{version}.js
44 ln -s scrollstop-%{version}.js $RPM_BUILD_ROOT%{_appdir}/scrollstop.src.js
45 ln -s scrollstop-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/scrollstop.js
46 ln -s scrollstop-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/scrollstop.min.js
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README.textile
54 %{_appdir}
This page took 0.100577 seconds and 3 git commands to generate.