]> git.pld-linux.org Git - SPECS.git/blob - jquery-hashchange.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / jquery-hashchange.spec
1 %define         plugin  hashchange
2 Summary:        jQuery hashchange event
3 Name:           jquery-%{plugin}
4 Version:        1.3
5 Release:        1
6 License:        MIT / GPL
7 Group:          Applications/WWW
8 Source0:        http://github.com/cowboy/jquery-hashchange/raw/v1.3/jquery.ba-hashchange.min.js
9 # Source0-md5:  757898a5793d29189e52ca6ee8fce808
10 URL:            http://benalman.com/projects/jquery-hashchange-plugin/
11 BuildRequires:  rpmbuild(macros) >= 1.268
12 BuildRequires:  js
13 BuildRequires:  yuicompressor
14 Requires:       jquery
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _appdir %{_datadir}/jquery/%{plugin}
19
20 %description
21 This jQuery plugin enables very basic bookmarkable #hash history via a
22 cross-browser HTML5 window.onhashchange event.
23
24 While this functionality was initially tied to the jQuery BBQ plugin,
25 the event.special window.onhashchange functionality has now been
26 broken out into a separate plugin for users who want just the basic
27 event & back button support, without all the extra awesomeness that
28 BBQ provides.
29
30 %prep
31 %setup -qcT
32 cp -p %{SOURCE0} %{plugin}.js
33
34 %build
35 # compress .js
36 install -d build
37 yuicompressor --charset UTF-8 %{plugin}.js -o build/%{plugin}.js
38 js -C -f build/%{plugin}.js
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_appdir}
43 cp -p build/%{plugin}.js $RPM_BUILD_ROOT%{_appdir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %{_appdir}
This page took 0.032784 seconds and 3 git commands to generate.