]> git.pld-linux.org Git - SPECS.git/blob - job.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / job.spec
1 # TODO
2 # - optflags
3 Summary:        Linux Jobs
4 Summary(pl.UTF-8):      Narzędzia do obsługi zadań pod Linuksem
5 Name:           job
6 Version:        1.5.0
7 Release:        0.1
8 License:        GPL
9 Group:          Applications/System
10 Source0:        ftp://oss.sgi.com/projects/pagg/download/%{name}-%{version}.tar.gz
11 # Source0-md5:  4cc7c983765c934e33d4078bf530a978
12 URL:            http://oss.sgi.com/projects/pagg/
13 Requires(post,preun):   /sbin/chkconfig
14 Requires:       rc-scripts
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The job package provides a set of commands, a PAM module, man pages,
19 and configuration files. The commands are used to send signals to
20 jobs, wait on jobs, get status information about jobs, and for
21 administrators to control process attachment to jobs. The PAM module
22 allows the administrator to specify which point-of-entry services on
23 the system (rlogin, gdm, xdm, ftp, etc.) should create new jobs.
24
25 %description -l pl.UTF-8
26 Pakiet job dostarcza zestaw poleceń, moduł PAM, strony podręcznika
27 oraz plik konfiguracyjny. Polecenia służą do wysyłania sygnałów do
28 zadań, oczekiwania na zadania, odczytu informacji o zadaniach oraz dla
29 administratorów do kontroli dołączania procesów do zadań. Moduł PAM
30 umożliwia administratorowi określenie, które usługi wejściowe systemu
31 (rlogin, gdm, xdm, ftp itp.) powinny tworzyć nowe zadania.
32
33 %prep
34 %setup -q -n %{name}
35
36 %build
37 # TODO: optflags
38 %{__make} build \
39         ROOT="$RPM_BUILD_ROOT"
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         ROOT="$RPM_BUILD_ROOT"
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %preun
51 if [ "$1" = 0 ] ; then
52         SAFE=`fgrep -s pam_job.so /etc/pam.d/* | wc -l`
53         if [ $SAFE -ne 0 ] ; then
54                 echo "You must remove all references to pam_job.so in the "
55                 echo "/etc/pam.d/* config files before attempting to uninstall"
56                 echo "the job package."
57                 echo ""
58                 exit 1
59         fi
60         /sbin/chkconfig --del job
61 fi
62 exit 0
63
64 %post
65 /sbin/chkconfig --add job
66 echo "You must add references to pam_job.so in the /etc/pam.d/* config"
67 echo "files to enable the PAM services for creating jobs.  You only"
68 echo "need to add the reference for services that you want to fall under"
69 echo "job control."
70 echo ""
71 echo "Example entry when able to use session modules:"
72 echo ""
73 echo "    session    optional    /lib/security/pam_job.so"
74 echo ""
75 echo "Example entry when required to use account modules:"
76 echo ""
77 echo "    account    optional   /lib/security/pam_job.so"
78 echo ""
79 echo "Consult the %{_docdir}/job-1.4/README file for additional"
80 echo "information about the PAM module."
81 echo ""
82 exit 0
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS COPYING INSTALL README
87 %attr(755,root,root) %{_bindir}/jdetach
88 %attr(755,root,root) %{_bindir}/jkill
89 %attr(755,root,root) %{_bindir}/jsethid
90 %attr(755,root,root) %{_bindir}/jstat
91 %attr(755,root,root) %{_bindir}/jwait
92 %attr(755,root,root) %{_bindir}/jattach
93 %attr(755,root,root) %{_libdir}/libjob.so
94 %attr(755,root,root) /%{_lib}/security/pam_job.so
95 %attr(754,root,root) /etc/rc.d/init.d/job
96 %{_mandir}/*/*
97 # -devel?
98 #%{_includedir}/job.h
This page took 0.094704 seconds and 3 git commands to generate.