]> git.pld-linux.org Git - SPECS.git/blob - jimtcl.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / jimtcl.spec
1 Summary:        Small footprint implementation of Tcl programming language
2 Name:           jimtcl
3 Version:        0.76
4 Release:        1
5 License:        BSD
6 Group:          Development/Languages/Tcl
7 Source0:        https://github.com/msteveb/jimtcl/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  9ae9b0b685ee2df708c747ad7fce4d70
9 URL:            http://jim.tcl.tk/
10 BuildRequires:  asciidoc
11 BuildRequires:  tcl
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Jim is an opensource small-footprint implementation of the Tcl
16 programming language. It implements a large subset of Tcl and adds new
17 features like references with garbage collection, closures, built-in
18 Object Oriented Programming system, Functional Programming commands,
19 first-class arrays and UTF-8 support. All this with a binary size of
20 about 100-200kB (depending upon selected options).
21
22 %package devel
23 Summary:        jimtcl header files and development documentation
24 Group:          Development/Languages/Tcl
25 Requires:       %{name} = %{version}-%{release}
26
27 %description devel
28 jimtcl header files and development documentation.
29
30 %prep
31 %setup -q
32
33 %build
34 CC="%{__cc}" \
35 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
36 LDFLAGS="%{rpmldflags}" \
37 ./configure \
38         --prefix=%{_prefix} \
39         --full \
40         --shared
41
42 %{__make} all Tcl.html
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_libdir}
47
48 %{make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %if "%{_lib}" != "lib"
52 mv $RPM_BUILD_ROOT{/usr/lib/*,%{_libdir}}
53 %endif
54
55 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -s libjim.so{.%{version},})
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post   -p /sbin/ldconfig
61 %postun -p /sbin/ldconfig
62
63 %files
64 %defattr(644,root,root,755)
65 %doc AUTHORS BUGS DEVELOPING README* TODO
66 %attr(755,root,root) %{_bindir}/jimsh
67 %dir %{_libdir}/jim
68 %attr(755,root,root) %{_libdir}/libjim.so.%{version}
69
70 %files devel
71 %defattr(644,root,root,755)
72 %doc Tcl.html
73 %attr(755,root,root) %{_bindir}/build-jim-ext
74 %{_includedir}/jim*.h
75 %attr(755,root,root) %{_libdir}/libjim.so
This page took 0.061138 seconds and 3 git commands to generate.